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Глава 5. Чем сложнее модель, тем проще ее сформировать 

5.1. Как проще всего воспроизвести чужую модель 
 

В главе 2 мы уже воспроизводили модель аллена, опубликованную в книге [1]. Это стало 

мучительно, начиная с момента ввода силовых постоянных. Постараемся выяснить 

причины и устранить их. 

Мы соблазнились возможностями панели Bstruct.mat облегчить наш труд при вводе в 

модель атомов, колебательных координат типов q и α. В результате у нас сравнительно 

быстро возникла модель, вполне подобная той, что была изображена на рисунке образца. 

Но у нашей модели получилась не та нумерация атомов и естественных колебательных 

координат, что у опубликованной модели. Это и затруднило перенос силовых и 

электрооптических параметров их книги в программу Umiu.mat. Пришлось составлять 

таблицы соответствия между двумя системами координат.  

Хорошо было бы так воспроизводить какую-то модель, взятую из литературы, чтобы не 

мучиться. Система LevInfinite предлагает такие средства. Есть возможность подготовить 

данные о литературной модели в такой форме, которая обеспечит буквальное 

воспроизведение модели в плане нумерации атомов, значений их декартовых координат, 

нумерации колебательных координат типов q и α. Все эти данные могут быть распознаны, 

препарированы и усвоены системой LevInfinite вполне автоматизировано. Нам остается 

потрудиться над вводом колебательных координат типов γ и χ. Обычно это составляет 

малую часть работы над системой колебательных координат модели. 

Пусть нам понадобилась модель бутана из книги [2], страница 33.  

В системе LevInfinite, в папке Molecules создадим новую пустую папку ButaneML. 

С помощью любого текстового редактора создадим в этой папке файл InfTable.txt с таким 

содержимым 

          14          13          24          0           0           0 

          37           1  

Затем надо создать несколько текстовых файлов, буквально или почти буквально 

повторяющих те файлы, которые создает панель Bstruct.mat по команде File -> txt-files for 

calculations. В файлах важно соблюдать форму представления данных. Поэтому проще 

всего поступать так. Скопируем в папку ButaneML из папки какой-то уже имеющейся у 

нас модели файлы  

AtomCoords.txt 

AtomMasses.txt 

AtomSymbols.txt 

BaStructures.txt 

BqStructures.txt 
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Далее будем редактировать содержимое каждого файла так, чтобы сохранялось 

расположение данных по строкам и столбцам. Однако необязательно соблюдать форматы 

вводимых чисел. MatLab, читая данные из внешних файлов по команде load(‘имя 
текстового файла’), легко превращает их в соответствующие строки и столбцы 

одноименных массивов. При этом никаких проблем с форматами не возникает, что очень 

облегчает нам жизнь. 

 

Несколько советов по технике приготовления указанных выше файлов. Составить файлы 

AtomMasses.txt и AtomSymbols.txt не составит труда. Это можно сделать вручную. Для 

остальных файлов можно предложить услуги любой программы OCR (Optical Character 

Recognition), например, FineReader. Надо отсканировать, распознать и сохранить в виде 

текстовых файлов следующие таблицы из книги 

 

Координаты атомов x y z (в Å) 

Номера координат и образующих их атомов 

 

Далее с помощью текстового редактора надо переносить данные из системы OCR в 

нужные нам файлы модели ButaneML.  

 

При редактировании указанных файлов надо иметь в виду, что в файлах BqStructures.txt и 

BaStructures.txt при формировании новой модели понадобятся только номера атомов. Они 

стоят в начале каждой строки. Если вы редактируете скопированные из другой папки 

файлы, то все продолжения строк можно удалить. 

 

Особого внимания требует файл AtomCoords.txt. Дело в том, что при распознавании 

симметрии модели и при работе с характерными силовыми и электрооптическими 

параметрами программам нужна некоторая точность представления координат атомов в 

равновесном состоянии модели. Симметрично расположенные атомы должны быть 

расположены в декартовых координатах симметрично (выражаясь тавтологично), а у 

характерных взаимодействиях пар колебательных координат должны быть одинаковыми 

главные моменты инерции.  

 

Реплика в сторону. Очень соблазнительно обратиться к программе ChemOffice, чтобы записать брутто-

формулу или название исследуемого соединения и получить одним кликом мышки профессиональный 
рисунок модели молекулы, декартовы координаты всех атомов и матрицу смежности для валентных связей. 
Эти числовые данные хорошо бы ввести в перечисленные выше текстовые файлы и на такой основе 
построить нашу колебательную модель, поскольку результаты команды Molecular Dynamics системы 
ChemOffice нас не удовлетворят. Да, мы увидим, как колеблется модель в окне ChemOffice, но мы никогда 
не узнаем, почему она так колеблется. Мы не сумеем выделить и проанализировать отдельные 
нормальные колебания из хаотической картины возбуждения всех нулевых и ненулевых колебаний 
буржуазной модели. А значения координат атомов нам будут предложены столь неточными, столь 
несимметричными и нехарактерными, что программы системы LevInfinite откажутся с ними работать. 

Придется сильно ухаживать за этими столь легко и просто полученными данными.  

 

Итак, с первого взгляда на приведенные в книге [2] данные по координатам атомов 

становится ясно, что большие машины знаменитой серии ЕС ЭВМ накапливали большие 

ошибки при расчетах. Хорошо еще, что нам не обязательно разбираться с этими 

ошибками. Мне кажется, что достаточно привести данные из книги к нужной точности 

представления чисел в файле AtomCoords.txt – четыре значащих цифры после десятичной 

точки. Это потребует простого округления чисел. И все станет как надо.  
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Например, атомы 1 и 6 в книжной модели бутана расположены симметрично 

относительно центра симметрии. Но при этом изображены в таблице декартовых 

координат так 

 

1 -0.5505977 -0.5404214 -0.0000001 

6  0.5505938  0.5404224  0.0000001 

Округлим и расположим числа в строках, убрав нумерацию строк. Получим пригодные 

для работы данные 

     -0.5506    -0.5404     0.0000 

      0.5506      0.5404     0.0000 

 

Проделав всю эту несложную работу, получим в папке ButaneML файлы с таким 

содержанием, отражающим информацию о модели, которую мы ходим заимствовать. 

 

После того, как подготовлены необходимые исходные файлы, запускаем MatLab, 

настраиваем Current Directory на LevInfinite\Programs и вызываем панель Bstruct. 

 

File -> Import txt Files 

 

 В диалоговом окне находим папку ButaneML и открываем в ней файл InfTable.txt. 

 

Убеждаемся, что на основе приготовленных текстовых файлов в панели Bstruct возникла 

полноценная визуальная модель молекулы бутана со всеми колебательными 

координатами типов q и α.  
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Эта модель хороша тем, что не требует введения колебательных координат других типов, 

если мы не хотим учесть внутренние вращения групп CH2 и CH3.  

File -> Save 

File -> txt-files for calculations 
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File -> Exit 

 

В папке ButaneML возник файл Bstruct.mat, хранящий все подробности модели, 

необходимые другим программам. Обновились все текстовые файлы. Некоторые из них 

не изменили своего содержания, но в файлах BqStructures.txt и BaStructures.txt, наряду со 

знакомыми нам номерами атомов, появились значения соответствующие элементов 

матрицы B.  

 

Далее приходим к самому неприятному моменту, к вводу силовых и электрооптических 

параметров модели бутана, обратившись к программе Umiu.m. 

 

File -> New Umiu for  

 

Естественно, для модели ButaneML.  

 

File -> Exit 

 

В папке ButaneML возник файл Umiu.mat и текстовый файл u_list.txt с нулевыми 

значениями силовых и электрооптических параметров. Этот файл надо сохранить под 

именем ulist.txt и внести в него значения параметров из таблиц книги [2].  Думаю, что 

редактирование файла ulist.txt можно автоматизировать с помощью офисных программ 

FineReader и Excel. Опытному пользователю предоставлена полная свобода действий, 

обеспеченная тем, что мне удалось сохранить хотя бы идейную совместимость структур 

данных в системе Lev каменного века и в современной системе LevInfinite. 

 

После сохранения отредактированного файла ulist.txt снова вызываем панель Umiu.m. 

 

File -> Open Bstuct-Umiu for 

Естественно, для модели ButaneML.  

Edit U-Miu -> Input ulist.txt with corrections 

Можно убрать все те строки из списка характерных параметров, где стоят нулевые 

значения.  

File -> Save Umiu.mat 

File -> Save Usparse.txt 

File -> Save Miu.txt DmdqSparse.txt 

File -> Exit 

 

Полегчало с вводом данных в файл ulist.txt? 

 

Можно и нужно обратиться к программам symlev.exe, MatrixT.m, diag1.m.  

 

Обращаемся также к программам MatrixU.m и diag2.m. 

В папке ButaneML возник файл freqs.txt и другие файлы с результатами решения задачи о 

колебаниях модели бутана. Имеет смысл сравнить полученные частоты с приведенными в 

книге. Если частоты оригинала удалось воспроизвести в нашем расчете, значит все 

параметры модели, кроме, возможно, электрооптических, введены правильно. 

 

Далее обращаемся к программе intir.m. убеждаемся, что программа intir.m дает 

правильные значения интенсивностей. Тем самым, подтверждается правильность ввода 

всех электрооптических параметров. Затем приготавливаем файл sigma.txt в папке 

ButaneML и обращаемся к программе IRcurve.m. Любуемся теоретической кривой ИК 

поглощения модели бутана. 
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Замечания о координатах других типов 

Модель бутана была хороша тем, что содержала координаты простых типов, q и α. Покажем 

теперь, что надо делать, если модель содержит колебательные координаты и других типов. 

 

Ввод координат типа ρ также не сложен. Надо отразить в файле InfTable.txt нужное число 

координат этого типа (пятое число в первой строке текста) и приготовить файл 

BrStructures.txt. В каждой строке этого файла должно стоять 4 номера атомов, входящих в 

описание данной координаты. Первые три атома определяют плоскость, а четвертый атом 

выходит из этой плоскости. Считается, что четвертый атом является концевым атомом той 

связи, которая связывает этот атом с центральным атомом той тройки атомов, которая 

определяет плоскость. Направление выхода связи из плоскости определяется правилом 

буравчика. Двигаясь от первого атома через второй, центральный атом валентного угла, 

лежащего в этой плоскости, к третьему атому, мы определяем направление вращения 

буравчика. Тем самым, определим направление движения четвертого атома. 

Если файл BrStructures.txt позаимствован из более ранней версии наших программ 

визуального моделирования колебаний молекул, то его можно подать на вход данной 

программы и команды File -> Import txt Files безо всяких изменений. 

 

Сложнее обстоит дело с координатами типов γ и χ. Если файлы BgStructures.txt и 

BhStructures.txt позаимствованы из более ранней версии наших программ визуального 

моделирования колебаний молекул, то они содержат недостаточно информации для 

автоматического построения координат этих типов в системе описанных здесь программ.  

Данная программа и команда File -> Import txt Files позаимствует из этих файлов номера 

атомов, входящих в описания данных координат. Но нельзя автоматически распознать, 

куда должен быть направлен изгиб линейного участка молекулы в координате типа γ и как 

надо сформировать оси вращения в координате типа χ. Поэтому программа, введя 

информацию о номерах атомов из файлов BgStructures.txt и BhStructures.txt, 

предупреждает в командном окне MatLab, что координаты γ и χ надо откорректировать 

вручную. Делается это так. 
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После выполнения команда File -> Import txt Files надо в командном окне MatLab дать 

команду  

 

global Gammas 

 

global His 

 

для требуемого типа координат. В окне WorkSpace появятся пиктограммы 

соответствующих массивов. Двойным кликом мышки по такой пиктограмме можно 

вызвать содержимое соответствующего массива и внести в массив либо номера векторов, 

задающих направления изгиба или направления оси, либо пары атомов, через которые эти 

направления будут вычисляться при пересчете файлов BgStructures.txt и BhStructures.txt 

командой File -> txt-files for calculations.  

Для координаты типа γ номер вектора изгиба надо внести в четвертую позицию в строке. 

Нужный номер можно отчитать в списке единичных векторов на панели программ. Если 

же надо указать направление парой номеров атомов, то эти номера надо внести в позиции 

5 и 6. Этот способ задания направления более предпочтителен, если предполагается 

использовать данную модель в качестве фрагмента при построении более крупных 

моделей. 

Так же надо поступать при редактировании координаты типа χ. Для первой плоскости 

номер вектора оси поворота этой плоскости вносится в позицию 4, а номера пары атомов 

– в позиции 5 и 6. Для второй плоскости этой же координаты используются, 

соответственно, позиция 10 для номера вектора и позиции 11 и 12 для номеров пары 

атомов. Способ задания направления осей парами атомов более предпочтителен, если 

предполагается использовать данную модель в качестве фрагмента при построении более 

крупных моделей. 

 

После ручной коррекции массивов необходимо дать команды  

File -> Save 

File -> txt-files for calculations 

File -> Exit 
 

5.2. Алмазная пыль 

 

До сих пор мы знакомились с программами, размещенными в папке LevInfinite\Programs. 

Такие программы принято называть сервисными. Потому, наверное, что они нам 

оказывают услуги, а мы не должны за ними ухаживать. Как принято говорить – 

сопровождать эти программы.  

 

Предлагаю познакомиться с программой иного типа, которую сервисной никак не 

назовешь. Такие программы в моей практике возникают довольно часто, когда мне надо 

решить сравнительно частную проблему, как-то связанную с колебаниями молекул. Я 

тогда пишу m-скрипт, не заботясь о пользовательском интерфейсе, раз я единственный 

пользователь. Часто не забочусь о вводе данных в программу из внешних файлов, а 

просто вписываю в скрипт подходящие операторы присваивания значений переменным и 

массивам данных. На всякий случай храню эти программы в какой-то папке, 

расположенной вне LevInfinite\Programs, чтобы не нарушать целостность системы 

сервисных программ. Назначив эту папку в качестве рабочей директории MatLab, я 

размещаю в ней некоторые файлы, скопированные из системы LevInfinite, если надо 

ввести в программу данные из этих файлов. В эту же папку я вывожу результаты расчетов. 

Если такие результаты годятся для дальнейшего использования сервисными программами 



7 
 

системы LevInfinite, я копирую туда файлы с полученными результатами. Это избавляет 

m-скрипты от необходимости настраиваться на полные пути таких файлов. В результате, 

m-скрипты получаются короткими и прозрачными. В случае необходимости обратиться к 

данной частной проблеме еще раз, я легко восстанавливаю в памяти алгоритм расчета 

прямо по тексту скрипта, правлю его, если надо, и быстро получаю новые результаты. 

 

В качестве примера я привожу здесь проблему, возникшую у нас при освоении техники 

программирования параллельных вычислений на суперкомпьютере МВС-1000.  

 

У Л.А. Грибова возникла идея воспользоваться суперкомпьютером для решения задач о 

колебаниях молекулярных моделей особо крупных размеров. Я написал такие программы. 

Их надо было не только отладить, но и получить представление, насколько крупными 

моделями можно оперировать с помощью таких программ, какое время счета потребуется. 

У меня заодно возникла идея воспользоваться этой ситуацией для решения одной 

физической проблемы, которая долго не давала мне покоя – где лежит предел 

применимости молекулярного подхода к моделированию протяженных систем типа 

полимеров и кристаллов. Ясно же, что когда-то надо перестать описывать каждый атом и 

каждую валентную связь в веществе и переходить к моделям физики твердого тела. Но 

когда и почему? Какие причины могут сделать нашу теорию и вычислительные приемы 

неадекватными кристаллической и полимерной действительности, если мы хотим 

работать не с бесконечными кристаллами и полимерами. Если мы хотим исследовать 

наноразмерные частицы, содержащие многие тысячи атомов. А мы хотим. 

 

Тогда возникла чисто техническая проблема. Где взять тестовую молекулярную модель, 

которую можно было бы с легкостью расширять, доводя ее до пределов возможностей 

суперкомпьютера и наших вычислительных приемов. Я быстро понял, что это должна 

быть молекулярная модель кристалла с простой структурой элементарной ячейки. Не 

модель молекулярного кристалла, где элементарная ячейка содержит несколько 

сравнительно сложных молекул. С такой моделью можно быстро замучиться. Нет, это 

должна быть модель истинного кристалла, но описанная в форме модели крупной 

молекулы. Это мы и называем молекулярным представлением модели кристаллита, 

учитывающим реальные размеры и внешнюю форму исследуемого объекта. Очень 

хотелось на практике доказать самому себе тезис – чем сложнее модель, тем проще ее 

сформировать.  

 

Я выбрал элементарную ячейку алмаза. Чтобы вычислить значения декартовых координат 

атомов, мне было удобно положить период решетки равным единице. Получился такой 

список координат атомов в условной элементарной ячейке с единичным периодом 

решетки типа алмаза. 

 
     0.0000     0.5000     0.5000  
     0.2500     0.7500     0.7500  
     0.5000     1.0000     0.5000  
     0.7500     0.7500     0.2500  
     0.5000     0.5000     0.0000  
     0.2500     0.2500     0.2500  
     0.5000     0.0000     0.5000  
     0.7500     0.2500     0.7500  
     0.0000     0.0000     0.0000  
     1.0000     1.0000     0.0000  
     1.0000     0.5000     0.5000  
     1.0000     0.0000     1.0000  
     0.5000     0.5000     1.0000  
     0.0000     1.0000     1.0000 
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Поучилась такая картина 
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Умножив все координаты атомов на значение истинного периода решетки 3.56 Å, я 

получу реальную картину. Далее, последовательно транслируя эту модель вдоль осей 

координат на период решетки и на кратные ему векторы трансляции, я смогу быстро 

наращивать размеры модели. Надо только учесть, что при трансляции некоторые атомы 

нового экземпляра ячейки накладываются на старые атомы. Дублирование атомов надо 

автоматически распознать и устранить. Вот и вся идея вспомогательного вычислительного 

алгоритма, который мне нужен, чтобы получать такие исходные данные для панели 

Bstruct.m, которые мы в предыдущем разделе главы приготавливали вручную.  

 

Описанный алгоритм реализован в скрипте cryst_atoms.m, находящемся в  папке 

LevInfinite/Progams/Utilits. Я задал в его тексте три трансляции вдоль осей x, y, z на 

постоянную решетки. В результате получил текстовые файлы, пригодные для ввода в 

панель Bstruct.m. Получил модель кристаллита алмаза размером 2х2х2 элементарных 

ячейки. Это очень маленькая алмазная пылинка, ее поперечник составляет всего лишь 

половину нанометра. Но в молекулярном представлении это уже крупная модель, 

содержащая 91 атом углерода.  

После ввода приготовленных с помощью скрипта cryst_atoms.m файлов в панель 

Bstruct.m, я воспользовался командами автоматического распознавания и формирования 

всех координат растяжений связей между соседними атомами, а также ввода всех 

координат изменения валентных углов. Получилось 128 колебательных координат типа q 

и 300 координат типа α. Всего модель содержит 428 колебательных координат. Программа 

symlev.exe распознала у модели группу симметрии Td и построила матрицу 

преобразования симметрии, приведшую колебательное уравнение к 10 блокам симметрии. 

 

С помощью панели Umiu.m я ввел всего 5 характерных силовых постоянных, которые 

позаимствовал из книги [3]. Там приведены данные для модели циклогексана. Структура 

решетки алмаза представляет собой систему конденсированных циклогексановых 

скелетов, поэтому я мог смело воспользоваться силовыми постоянными скелетной части 
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циклогексана, чтобы сформировать матрицу силовых постоянных алмаза в первом 

приближении. 

 

Расчет дал 267 ненулевых частот, как и должно быть по теории. Вот как выглядит 

полученная в результате всех невеликих усилий модель кристаллита алмаза размером 

2х2х2 элементарных ячейки. Вы можете легко повторить этот расчет и наблюдать с 

помощью программы MolView.exe все нормальные колебания этой решетки.  

  
 

Если надо получить более крупную модель, то надо в качестве исходных данных взять 

координаты атомов этой модели. В скрипте надо изменить заказ на трансляцию – теперь 

надо протранслировать модель на расстояния, равные двум периодам решетки. Получится 

модель размером 4х4х4 элементарных ячейки. 

 

Что удалось найти в алмазной пыли 

 

Были рассчитаны частоты кристаллитов различного размера и различной формы. 

Оказалось, что частотный спектр модели кристаллита весьма чувствителен к форме и 

размерам объекта. Это уже хорошо для тех специалистов, которые разрабатывают 

технологию производства наночастиц. На конференциях мне приходилось слушать 
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сообщения об экспериментальном обнаружении в ИК спектрах наночастиц различной 

природы некоторых признаков, позволяющих отличить крупные частицы от мелких. Но у 

докладчиков не было теоретических средств интерпретации этих признаков. Похоже, что 

мы могли бы предложить такие средства.  

 

Ниже приведена гистограмма частот в теоретическом спектре кристаллита алмаза 

размером 4х4х4 элементарных ячейки. Это уже один нанометр в поперечнике. 

 
Гистограмма частот колебаний модели алмаза размером 4х4х4 элементарных ячейки. 
 

Если сравнить эту гистограмму с аналогичной картиной для модели размером 4х4х2 

элементарных ячейки, то будет четко видна разница в низкочастотной части спектра. В 

остальных областях спектра гистограммы практически неотличимы. Следовательно, 

хороший эксперимент в далекой ИК области может оказаться чувствительным к форме 

нанокристаллитов. Алмаз не является хорошим примером, поскольку связи в его решетке 

неполярны, и он не дает богатого ИК спектра. Но другие вещества, обладающие 

различными наборами полярных связей, могут показать вполне надежные признаки 

размеров и форм кристаллитов. 

 

Выше я уже упоминал интересовавшую меня проблему  – где лежит предел применимости 

молекулярного подхода к моделированию протяженных систем типа полимеров и 

кристаллов. Это сложная проблема, имеющая множество аспектов. Я остановился на 

одном из них, – на вычислительном. Компьютерные эксперименты с кристаллитами 

алмаза позволили мне если не решить, то хотя бы прояснить эту вычислительную и 

программистскую проблему. Вот как выглядят частные вычислительные аспекты данной 

общей проблемы. 

 

При формировании колебательного гамильтониана молекулярной модели в 

естественных координатах трудно, а в ряде случаев невозможно избежать введения 

зависимых колебательных координат. В то же время при вычислении частот колебаний 
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необходимо перейти к независимым нормальным координатам. В поисках выхода из этой 

противоречивой ситуации был предложен метод исключения зависимостей между 

колебательными координатами на этапе диагонализации кинематической части 

колебательного гамильтониана. Этот алгоритм был реализован в наших программах. 

Многолетняя эксплуатация нескольких поколений таких программ показала высокую 

надежность метода и простоту его алгоритмической  реализации. Однако до сих пор 

вычислительными методами выполнялся теоретический анализ колебательных спектров 

не очень крупных молекул, содержащих не более 100 атомов. В последние же несколько 

лет возникла необходимость строить весьма крупные молекулярные модели, содержащие 

многие сотни атомов. Поэтому возник вопрос, будет ли указанный метод исключения 

зависимостей между координатами надежно работать в условиях диагонализации 

кинематической части колебательного гамильтониана очень большой размерности, вплоть 

до нескольких тысяч колебательных координат. 

Вторая проблема связана с накоплением погрешностей при выполнении 

многочисленных операций с плавающей точкой в процессе формирования и 

диагонализации матриц высокой размерности, какими являются машинные представления 

колебательных гамильтонианов крупных молекулярных моделей. Эта проблема не может 

быть решена чисто теоретически. Поэтому были выполнены компьютерные эксперименты 

с моделями кристаллитов алмаза. 

 

Для каждой модели мы, пользуясь описанным в выше методом, формировали систему 

ее колебательных координат. Такая система включает все координаты растяжений 

валентных связей между ближайшими атомами, а также все координаты изменений углов 

между всеми  валентными связями. Эта система колебательных координат полностью 

соответствует химическим представлениям об атомных взаимодействиях в кристаллите 

алмаза. Система таких координат содержит много «лишних» координат из-за множества 

циклов со структурой кольца циклогексана. Исключение «лишних» координат на этапе их 

формирования чрезвычайно затруднено даже для небольших по размеру моделей, а для 

крупных моделей эта операция становится практически невыполнимой. Кроме того, 

исключение «лишних» координат не позволяет учесть симметрию модели. Поэтому мы 

сохраняем все введенные координаты в гамильтониане модели. Если кинематическая 

часть гамильтониана (матрица Ts) составлена с математической точностью, то некоторые 

собственные числа этой матрицы получатся нулевыми. Нулей будет ровно столько, 

сколько линейных зависимостей существует между колебательными координатами. 

Остальные, ненулевые собственные числа соответствуют искомым нормальным 

колебаниям модели. Однако все вычислительные процедуры выполняются с 

ограниченной точностью, поэтому линейные зависимости в какой-то мере нарушаются. В 

результате ни одно из собственных чисел матрицы  Ts может не получиться нулевым. 

Возникает задача подобрать некий дискриминант и с его помощью отбросить те малые 

ненулевые собственные числа, которые соответствуют искаженным линейным 

зависимостям между колебательными координатами. Мы подбирали такое значение 

дискриминанта, чтобы на выходе программы диагонализации получалось теоретически 

ожидаемое число нормальных колебаний m, равное 

 m = N – 6, 

где N – число атомов в модели. 

Кроме того, для каждой модели мы программно просматривали полные результаты 

диагонализации матрицы Tp (Ts) и отмечали верхнюю и нижнюю границы «нулевых» 

собственных чисел, отвечающих зависимостям между естественными колебательными 

координатами модели, и нижнюю границу тех собственных чисел, которые соответствуют 
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нормальным колебаниям модели. Мы ожидали, что для некоторых моделей эти границы 

соприкоснутся, либо пересекутся, и тогда будет трудно назначить дискриминант для 

правильного решения указанной проблемы. Ожидалось, что такое сближение границ двух 

множеств собственных чисел будет наблюдаться при рекордно большой размерности 

матрицы Tp (Ts). Кроме того, следовало ожидать, что такое сближение будет более 

характерным для «одномерных» (нитевидных) моделей, где из-за высокой гибкости 

алмазной нити толщиной в одну элементарную ячейку с ростом длины нити будут 

появляться очень низкие по частоте нормальные колебания. Это явление могло быть 

характерным и для «двумерных», пленочных моделей толщиной в одну элементарную 

ячейку. Для «трехмерных» моделей алмаза, где изгибы всего кристаллита затруднены, 

такое явление должно быть менее характерным. 

 

Ниже приведены результаты численных экспериментов. Все модели были приведены к 

6 блокам симметрии, кроме модели размером 4х4х4 элементарных ячейки. Эта последняя 

модель была приведена к 10 блокам симметрии. Максимальный размер блока составлял 

512х512. Это позволило решить все задачи на ПК. Однако накопленный нами ранее опыт 

решения колебательных задач с учетом и без учета симметрии показывает, что результаты 

диагонализации колебательного гамильтониана получаются одинаковыми. Отсюда 

следует, что при работе с нерегулярными молекулярными средами на суперкомпьютере 

МВС-1000 мы получим сходные результаты.  

В результате проведенных экспериментов показано, что для всех исследованных 

моделей дискриминант, равный 1*10
-6

, обеспечивает удачный поиск и исключение 

«нулевых» собственных чисел кинематической части молекулярного гамильтониана. 

Такие собственные числа связаны с искаженными в результате накопления 

вычислительных погрешностей линейными зависимостями между колебательными 

координатами. Подробные данные об исследованных моделях приведены в таблице 1. 

 

Таблица 1. Характеристики моделей и результаты расчетов при значении 

дискриминанта, равном 1*10
-6

. 

Модель 

алмаза, 

число ячеек 

Атомов Координат Частот Наименьшее 

собственное 

число 

матрицы Ts 

Отброшены 

числа в 

диапазоне min, 

max  

Наименьшая 

частота, см
-1

 

2 27 96 75 1.8e-3 -4e-8,   7e-8 54.6 

4 53 196 153 3e-4 -6e-8,   5e-8 21.7 

8 105 396 309 3e-5 -7e-8,   6e-8 6.4 

16 209 796 621 1.8e-6 -7e-8,   7e-8 1.7 

32 417 1596 1245 1.23e-7 -7e-8,   7e-8 4.5e-1 

2x2 50 202 144 3e-3 -8e-8,   1e-7 73 

4x4 182 850 540 7e-4 -8e-8,   9e-8 33 
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8x8 686 3490 2052 7.4e-5 -9e-8,   9e-8 11 

4x4x2 327 1812 975 2e-3 9e-8,   1e-7 73.5 

4x4x4 617 3736 1845 2.5e-3 -2e-7,   2e-7 103 

 

Более подробную информацию о поведении моделей дают гистограммы собственных 

чисел матриц Ts исследованных моделей. На рисунке приведены гистограммы двух 

множеств собственных чисел матрицы Ts модели алмаза размером 4х4х4 элементарных 

ячейки. Слева на рисунке дана гистограмма «нулей». Эти числа лежат ниже выбранного 

значения дискриминанта и отброшены программой на выходе из процедуры 

диагонализации.  Справа на рисунке дана гистограмма тех собственных чисел матрицы Ts, 

которые соответствуют нормальным колебаниям модели.  

 

Слева – гистограмма малых собственных чисел матрицы Ts модели алмаза размером 

4х4х4 элементарных ячейки. Эти числа соответствуют искаженным из-за погрешностей 

вычислений линейным зависимостям между колебательными координатами модели. 

Справа – собственные числа матрицы Ts, соответствующие нормальным колебаниям 

модели. Нижняя граница чисел на этой гистограмме не ноль, а 2.5e-3.  

 

Из полученных результатов видно, что даже в самой неблагополучной модели 

одномерной нити алмаза наименьший зазор между множеством следов искаженных 

зависимостей, которое надо отбросить, и множеством собственных чисел матрицы Ts 

модели составляет более полутора порядков. Так что значение дискриминанта уверенно 

находится. При этом наименьший наблюдаемый зазор был получен, когда уже давно 

наступило насыщение в распределении частот по зонам. Энергетические зоны полностью 
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сформировались при длине нити, равной 16 ячейкам. Зазор при этом составляет около 

двух порядков. При длине нити в 32 ячейки в энергетическом спектре уже ничего нового 

заметить невозможно. Следовательно, гнаться за моделированием очень большой длины 

нити не так уж целесообразно с физической точки зрения.  

В случае пленки и объемной модели зазоры составляют 3-4 порядка, так что при 

необходимости можно рассчитывать очень протяженные модели, не опасаясь потерять 

какие-то нормальные колебания. Из таблиц видно, что все примеры могли быть решены с 

дискриминатором 1*10
-6

.  

Подтверждается теоретическое предположение, что границы множества «нулей» слабо 

зависят от размеров модели, в то время, как нижняя граница настоящих собственных 

чисел матрицы Tp систематически снижается. В приведенных расчетах зазор между этими 

двумя множествами все время остается заметным, что позволяет с оптимизмом смотреть 

на проблему применимости предложенного и реализованного в наших программах приема 

учета зависимостей между колебательными координатами очень крупных молекулярных 

моделей. Полученные результаты также позволяют утверждать, что при анализе крупных 

колебательных моделей на суперкомпьютере МВС-1000 в режиме параллельных 

вычислений мы будем наблюдать сходные явления. Тем самым следует ожидать, что  

модельная и вычислительная граница между молекулярными представлениями 

химических объектов и представлениями их в виде сплошных нерегулярных сред будет 

определяться не проблемой перепутывания «нулей» с нужными собственными числами 

колебательного гамильтониана, а некоторыми иными проблемами. Эти проблемы сейчас 

трудно предвидеть, но они могут появиться с ростом размеров моделей, поэтому их 

предстоит исследовать в дальнейшем. 

 

Вниманию тех читателей, кому по ряду причин понадобится продолжить эти 

эксперименты для более сложных моделей. Для таких читателей я включил в папку 

LevInfinite/Programs программы diag1.exe, diag2.exe, написанные на Фортране. Они 

несколько отличаются от программ diag1.m, diag2.m как раз тем, что приспособлены для 

проведения таких экспериментов. Программа diag1.exe, наряду с уже упомянутыми в 

главе 1 стандартными текстовыми файлами, выдает файл TpEig.txt, содержащий все 

собственные числа матрицы Tp. Анализируя эти числа, можно прояснить описанную выше 

проблему для конкретного ряда моделей. Следует иметь в виду, что для подбора значения 

дискриминатора надо поместить файл Discrim.txt в папку модели. Образец этого файла я 

привел в папке LevInfinite/Config. Программа diag1.exe проверяет, есть ли в папке модели 

этот файл. Если он есть, то программа меняет стандартное значение дискриминатора на 

приведенное в файле. Это и позволяет легко руководить компьютерным экспериментом. 

5.3. Как позаимствовать параметры U и μ у родственной модели 
 

Вернемся к технологии воспроизведения чужих моделей. Такие технологии составляют 

важную часть рутинной научной работы. Экспериментаторы непрерывно повторяют 

чужие эксперименты с целью подтвердить недавно сделанное открытие новых явлений,  

либо с целью закрытия тех явлений, которые почему-то привиделись их открывателям. 

Экспериментаторам приходится воспроизводить самодельные приборы и условия 

экспериментов, описанные в оригинальных статьях. И на это тратятся силы и время. 

Теоретикам в этом плане проще. Было бы и совсем просто, если бы в современных 

журналах приводились полные выводы рабочих формул и полные тексты оригинальных 

вычислительных программ, да еще полные описания числовых данных для 

использованных в расчетах  моделей. Тогда можно было бы буквально повторить любой 

чужой расчет, сравнить результаты со своим расчетом и сделать обоснованный вывод в 

пользу или во вред того нового эффекта, который был обнаружен в чужом 
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вычислительном эксперименте. К сожалению, современные публикации такой полнотой 

описания условий эксперимента не страдают. Ради контраста, я мог бы предложить 

читателю воспроизвести мои эксперименты с моделями алмазов, описанные в 

предыдущем разделе главы. Вот вам способ приготовления моделей, вот вам мои 

программы. Попробуйте опровергнуть найденный мною новый эффект –испорченные 

нулевые значения собственных чисел матрицы Tp модели, содержащей зависимые 

колебательные координаты, следуют нормальному распределению с ограничениями; при 

этом параметры распределения не меняются с ростом размерности модели. А вдруг на 

ваших собственных моделях обнаружится, что этот эффект не является всеобщим, что он 

подтверждается только для алмазных пылинок? Буду рад узнать об этом. 

 

А сейчас предлагаю в качестве полезного упражнения разобраться с несколько запутанной 

ситуацией, описанной в литературе . 

 

Сложная ситуация с параметризацией моделей метил-ацетилена и диметил-

ацетилена 

 

Пусть нам понадобились эти две родственные модели. Воспроизведем их из книги [1 ], 

заранее настроившись на повторяемость структурных группировок и их эмпирических 

параметров. Эта повторяемость прямо используется в данном источнике при описании 

двух моделей.  

 

В описании диметилацетилена на странице 45 приведены 8 характерных силовых 

постоянных этой модели. Далее сказано «Остальные элементы матрицы U, как в 

метилацетилене». Это значит, что в данной модели имеются атомные группировки, 

буквально совпадающие с какой-то группировкой другой модели. И поэтому нечего 

тратить бумагу на переписывание повторяющихся силовых постоянных. Источник был 

нами издан в 1987 году, когда Партия сказала – экономика должна быть экономной. Мы 

ответили – есть! То есть – ладно, заглянем в метилацетилен и при необходимости спишем 

недостающие параметры оттуда. 

 

Заглядываем в описание метилацетилена и на странице 38, действительно, находим 

недостающие силовые постоянные. Но когда мы хотим рассчитать интенсивности в ИК 

спектре метилацетилена, то ищем на странице 40 электрооптические параметры, которые 

надо ввести в модель. Часть их находим. А про значительную часть сказано «Остальные 

значения электрооптических параметров, как в диметилацетилене». Ничего себе 

экономная экономика? 

 

Так вот, далее я покажу, что описанные здесь программы позволяют легко справиться 

даже с такой искусственно запутанной ситуацией. Действуйте дальше вместе со мной. И 

мы выпутаемся. 

 

Воспользуемся техникой, описанной в разделе 5.1, и приготовим входные текстовые 

файлы для модели метилацетилена. 

 

InfTable.txt  

          7          6          6          0           0           0 

          12           1  

 

AtomCoords.txt 

     0.0000     0.0000     1.3688  

     0.0000     0.0000     0.1618  
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     0.0000     0.0000    -1.2982  

     0.0000     0.0000     2.4248  

     1.0295     0.0000    -1.6622  

    -0.5148    -0.8916    -1.6622  

    -0.5148     0.8916    -1.6622 

 

AtomMasses.txt 

    12.0000  

    12.0000  

    12.0000  

     1.0880  

     1.0880  

     1.0880  

     1.0880 

 

AtomSymbols.txt 

C  

C  

C  

H  

H  

H  

H 

 

BqStructures.txt 

   1   2   

   2   3  

   1   4    

   3   5   

   3   6  

   3   7   

 

BaStructures.txt 

   2   3   5    

   2   3   6  

   2   3   7    

   5   3   6   

   5   3   7     

   6   3   7 

 

Разместим все эти файлы в новой папке MeAcetileneML. Запускаем MatLab, настраиваем 

Current Directory на LevInfinite\Programs и вызываем панель Bstruct. 

 

File -> Import txt Files 

 

 В диалоговом окне находим папку MeAcetileneML и открываем в ней файл InfTable.txt. 

 

Убеждаемся, что на основе приготовленных текстовых файлов в панели Bstruct возникла 

полноценная визуальная модель молекулы метилацетилена со всеми колебательными 

координатами типов q и α.  
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Эта модель требует дополнительного введения колебательных координат типа γ. Мы 

собираемся автоматически учесть симметрию модели. А это значит, что симметрия 

системы колебательных координат должна быть не ниже, чем симметрия системы атомов. 

Поэтому мы должны на каждом линейном участке модели ввести не две координаты 

излома этого участка, как требует физика, а три. Возникнет локальная система из трех 

зависимых координат γ1 + γ2 + γ3 = 0. Это не должно нас смущать и заставлять 

задумываться, как избавиться от этой линейной зависимости. Из предыдущего раздела и 

всех книг Л.А. Грибова мы знаем, что предлагаемые здесь программы легко справляются 

с проблемой «лишних» колебательных координат. 

 

Следовательно, наша задача – направить изломы в координатах типа γ так, чтобы эти 

изломы были согласованными с направлениями связей C3H5, C3H6, C3H7. Панель Bstruct 

позволяет этого добиться следующими командами. 

 

Angle coords -> Add Gammas 

Atoms to form Gamma 1  2  3    Bend direction   Pair atoms unit vector     Add Gamma 

        3    5 

Atoms to form Gamma 1  2  3    Bend direction   Pair atoms unit vector     Add Gamma 

        3    6 

Atoms to form Gamma 1  2  3    Bend direction   Pair atoms unit vector     Add Gamma 

        3    7 

Atoms to form Gamma 2  1  4    Bend direction   Pair atoms unit vector     Add Gamma 

        3    5 

Atoms to form Gamma 2  1  4    Bend direction   Pair atoms unit vector     Add Gamma 

        3    6 

Atoms to form Gamma 2  1  4    Bend direction   Pair atoms unit vector     Add Gamma 

        3    7 

Проверяем правильность ввода координат типа γ. 

View g  



18 
 

Close View 

File -> Save 

File -> txt-files for calculations 

 

File -> Exit 

 

В этот момент я настоятельно советую обратиться к программе simlev.exe. Это могучее 

средство логической проверки всей работы по визуальному моделированию 

кинематической части колебательного гамильтониана молекулы. 

 

simlev.exe 

 

Все в порядке. Файл Errors.txt пустой. Его можно удалить, чтобы не раздражал. В файле 

Symmetry.txt видно, что правильно распозналась группа симметрии C3v, причем к системе 

колебательных координат нет никаких претензий. Можно работать дальше. 

 

Вниманию пользователей системы визуального моделирования колебаний молекул. 

Я настоятельно советую при введении координат типа γ и χ не пользоваться готовыми 

координатными ортами в качестве единичных векторов для указания направления изгиба 

линейного участка модели или в качестве оси вращения. Дело в том, что  при переносе 

молекулярного фрагмента в другую модель локальная система координат фрагмента 

обязательно изменится. Тогда ссылка на готовый координатный орт станет 

недействительной. А если связать направление изгиба или направление оси вращения с 

атомами самого фрагмента, то при переносе такой системы атомов в другую модель 

способ вычисления необходимого вектора никак не изменится, результат формирования 

данной колебательной координаты никак не пострадает.  

Эти соображения и рекомендации станут полностью понятными после ознакомления с 

техникой использования молекулярных фрагментов. Сейчас я поясняю, почему я не 

пользуюсь более простой формы команды Angle coords -> Add Gammas. 

Конец обращения к пользователям. 

 

Вниманию разработчиков программ. 

В этот момент остро чувствуется принципиальная разница между колебательными 

координатами типов q и α с одной стороны, и γ, ρ, χ  с другой стороны. Координаты 

первой группы могут быть заданы в панели Bstruct очень простыми командами. Мы 

указываем единственных образец координаты типа q для пары атомов. Программа 

Bstruct.m послушно находит все пары атомов в модели, расстояния между которыми 

равно заданному в образце. И вводит в модель всю совокупность подобных координат. С 

координатами типа α еще проще. По соответствующие команде программа Bstruct.m сама 

находит и вводит полную систему этих координат. И никаких проблем с симметрией 

системы таких координат не возникает. 

 

С координатами второй группы так просто обойтись не получается. Никакая программа 

самостоятельно не догадается, куда надо сломать линейный участок модели в координате 

типа γ. Как надо согласовать выходы связей из плоскостей в координатах ρ друг с другом 

и с координатами других типов. Как выбрать оси вращения в координатах χ. Как 

согласовать все это координатное хозяйство. Особенно в вырожденных типах симметрии. 

Этой проблеме посвящено немало страниц в книгах Л.А. Грибова. Причем сухой остаток 

может быть выражен так – пользователь программ должен быть умным и долго над этим 

думать. Печально. 
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Так вот, мы, разработчики сервисных программ, получаем шанс существенно облегчить 

жизнь пользователям наших программ. Поясню эту мысль на только что возникшем 

примере координат типа γ. Умному пользователю было бы приятно, если бы, умно введя  

первую координату приведенной выше командой 

(Angle coords -> Add Gammas 

Atoms to form Gamma 1  2  3    Bend direction   Pair atoms unit vector     Add Gamma 

        3    5), 

он смог бы воспользоваться несуществующей командой «Размножить эту координату в 

соответствии с имеющейся в модели осью симметрии третьего порядка». Аналогично для 

излома на участке 2  1  4. 

 

Я уверен, что построить такую процедуру и соответствующий интерфейс совсем не 

трудно. Образец уже имеется в предлагаемых программах. Почему я этого не сделал сам 

(позор на мою седую голову)? Это сложный вопрос, я не хочу в него углубляться. Вкратце 

– я не очень верю в появление массового пользователя этих программ и в необходимость 

их дальнейшей разработки. Ещѐ печальней. 

Конец обращения к разработчикам. 

 

Далее приходим к вводу силовых постоянных модели метилацетилена, обратившись к 

программе Umiu.m. С вводом электрооптических параметров пока повременим. 

 

File -> New Umiu for  

Естественно, для модели метилацетилена.  

File -> Exit 

 

В папке MeAcetileneML возник файл Umiu.mat и текстовый файл u_list.txt с нулевыми 

значениями силовых и электрооптических параметров. Этот файл надо сохранить под 

именем ulist.txt и внести в него значения силовых параметров из таблицы книги [1], 

страница 38.   

 

Получится файл ulist.txt с таким содержимым 

 

   1    1   24.3    0.0000   0.0000   0.0000 qq     1    2  

   1    2   0.2900      NaN   0.0000   0.0000 qq     1    2 /     2    3  

   1    3   0.3      NaN   0.0000   0.0000 qq     1    2 /     1    4  

   2    2   8.28   0.0000   0.0000   0.0000 qq     2    3  

   2    4   0.09      NaN   0.0000   0.0000 qq     2    3 /     3    5  

   2    7   0.52      NaN   0.0000   0.0000 qa     2    3 /     2    3    5  

   2   10   0.0000      NaN   0.0000   0.0000 qa     2    3 /     5    3    6  

   3    3   9.972   0.0000   0.0000   0.0000 qq     1    4  

   4    4   8.14   0.0000   0.0000   0.0000 qq     3    5  

   4    5   0.1      NaN   0.0000   0.0000 qq     3    5 /     3    6  

   4    7   0.35      NaN   0.0000   0.0000 qa     3    5 /     2    3    5  

   4    8   0.0000      NaN   0.0000   0.0000 qa     3    5 /     2    3    6  

   4   10   0.38      NaN   0.0000   0.0000 qa     3    5 /     5    3    6  

   4   12   0.0000      NaN   0.0000   0.0000 qa     3    5 /     6    3    7  

   4   13   0.0000      NaN   0.0000   0.0000 qg     3    5 /     1    2    3  

   4   14   0.0000      NaN   0.0000   0.0000 qg     3    5 /     1    2    3  

   7    7   0.92     NaN      NaN      NaN aa     2    3    5  

   7    8   -0.025      NaN      NaN      NaN aa     2    3    5 /     2    3    6  

   7   10   -0.034      NaN      NaN      NaN aa     2    3    5 /     5    3    6  

   7   12   0.0000      NaN      NaN      NaN aa     2    3    5 /     6    3    7  
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   7   13   0.0000      NaN      NaN      NaN ag     2    3    5 /     1    2    3  

   7   14   0.0000      NaN      NaN      NaN ag     2    3    5 /     1    2    3  

   7   16   0.1      NaN      NaN      NaN ag     2    3    5 /     2    1    4  

   7   17   0.0000      NaN      NaN      NaN ag     2    3    5 /     2    1    4  

  10   10   0.71      NaN      NaN      NaN aa     5    3    6  

  10   11   -0.025      NaN      NaN      NaN aa     5    3    6 /     5    3    7  

  10   13   0.0000      NaN      NaN      NaN ag     5    3    6 /     1    2    3  

  10   15   0.0000      NaN      NaN      NaN ag     5    3    6 /     1    2    3  

  13   13   0.29      NaN      NaN      NaN gg     1    2    3  

  13   14   0.0000      NaN      NaN      NaN gg     1    2    3 /     1    2    3  

  13   16   0.12      NaN      NaN      NaN gg     1    2    3 /     2    1    4  

  13   17   0.0000      NaN      NaN      NaN gg     1    2    3 /     2    1    4  

  16   16   0.23      NaN      NaN      NaN gg     2    1    4  

  16   17   0.0000      NaN      NaN      NaN gg     2    1    4 /     2    1    4 

 

Пока не удаляем ни из этого файла, ни из списка, который должен возникнуть в панели 

Umiu, строчек с нулевыми значениями всех параметров. Такие строчки могут 

понадобиться для ввода электрооптических параметров, которыми мы пока не 

занимаемся. 

 

После сохранения отредактированного файла ulist.txt снова вызываем панель Umiu.m. 

 

File -> Open Bstuct-Umiu for 

Естественно, для модели MeAcetileneML.  

Edit U-Miu -> Input ulist.txt with corrections 

File -> Save Umiu.mat 

File -> Save Usparse.txt 

File -> Exit 

 

Проверяем, получаются ли ожидаемые частоты. 

MatrixT 

diag1 

MatrixU 

diag2 

 

Файл freqs.txt содержит следующие частоты. 

      926.95      1383.34     2136.76    2923.90  

     3330.14     313.65       641.10      1044.46  

     1450.80     2975.86     313.64      641.09  

     1044.42     1450.90     2975.86      

Частоты совпадают с приведенными в источнике. Значит, мы правильно воспроизвели все 

параметры модели, включая силовые постоянные. С электрооптическими параметрами 

повременим, пока не получим модель диметилацетилена. 

 

Для работы с моделью диметилацетилена создаем папку DiMeAcML (фортрановская 

программа simlev.exe не умеет работать с очень длинными названиями папок, отсюда 

некоторая несвобода в выборе имен папок и моделей). В эту папку помещаем файлы, 

необходимые для формирования модели диметилацетилена с сохранением нумерации 

атомов и колебательных координат. Мы видели, что этот прием очень упрощает ввод 

силовых и электрооптических параметров. 

 

InfTable.txt  
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          10           9          12           0           0           3  

          21           1 

 

AtomCoords.txt 

     0.0000     0.0000    -0.6035  

     0.0000     0.0000    -2.0635  

     0.0000     0.0000     0.6035  

     0.0000     0.0000     2.0635  

     0.8916    -0.5147    -2.4275  

     0.0000     1.0296    -2.4275  

    -0.8916    -0.5147    -2.4275  

    -0.8916     0.5147     2.4275  

     0.0000    -1.0296     2.4275  

     0.8916     0.5147     2.4275 

 

Внимание! Это не совсем те значения координат, что в источнике. О.В. Новоселова, по-

видимому, нашла в литературе, что длины связей CH в метильных группах этого 

соединения равны 1.097 Å. С этими геометрическими параметрами она решила обратную 

задачу о значениях силовых и электрооптических параметров. У нас сейчас несколько 

иная задача. Мы хотим в этой модели полностью воспроизвести геометрию и силовые 

параметры группировки C – CH3 из модели метилацетилена. Поэтому я изменил 

координаты атомов модели диметилацетилена так, чтобы и в ней длины связей CH в 

метильных группах были равны 1.092 Å. Это мало повлияет на значения частот, 

рассчитанных с предлагаемыми в источнике силовыми параметрами. Зато мы будем иметь 

возможность легкого переноса силовых постоянных из модели метилацетилена в модель 

диметилацетилена. 

 

AtomMasses.txt 

    12.0000  

    12.0000  

    12.0000  

    12.0000  

     1.0880  

     1.0880  

     1.0880  

     1.0880  

     1.0880  

     1.0880 

 

AtomSymbols.txt 

C  

C  

C  

C  

H  

H  

H  

H  

H  

H 

 

BqStructures.txt 
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   1   2   

   3   1   

   3   4   

   2   5  

   2   6    

   2   7   

   4   8   

   4   9    

   4  10   

 

BaStructures.txt 

   1   2   5   

   1   2   6  

   1   2   7   

   5   2   7   

   5   2   6  

   6   2   7    

   3   4   8    

   3   4   9   

   3   4  10    

   8   4  10   

   9   4   8   

   9   4  10   

 

Разместим все эти файлы в новой папке DiMeAcML. Запускаем MatLab, настраиваем 

Current Directory на LevInfinite\Programs и вызываем панель Bstruct. 

 

File -> Import txt Files 

 

 В диалоговом окне находим папку DiMeAcML и открываем в ней файл InfTable.txt. 

 

Убеждаемся, что на основе приготовленных текстовых файлов в панели Bstruct возникла 

полноценная визуальная модель молекулы метилацетилена со всеми колебательными 

координатами типов q и α.  

 



23 
 

-1

-0.5

0

0.5

1

-2

-1

0

1

2
-3

-2

-1

0

1

2

3

H5

H10

x

H9

C1

C2

C3

C4

H6

H7

y

H8

z

 
Эта модель также требует дополнительного введения колебательных координат типа γ. 

Мы собираемся автоматически учесть симметрию модели. А это значит, что симметрия 

системы колебательных координат должна быть не ниже, чем симметрия системы атомов. 

Поэтому мы должны на каждом линейном участке модели ввести не две координаты 

излома этого участка, как требует физика, а три.  

 

Выполняем в панели Bstruct следующие команды. 

 

 

Angle coords -> Add Gammas 

Atoms to form Gamma 2  1  3    Bend direction   Pair atoms unit vector     Add Gamma 

        2    5 

Atoms to form Gamma 2  1  3    Bend direction   Pair atoms unit vector     Add Gamma 

        2    6 

Atoms to form Gamma 2  1  3    Bend direction   Pair atoms unit vector     Add Gamma 

        2    7 

Atoms to form Gamma 1  3  4    Bend direction   Pair atoms unit vector     Add Gamma 

        4    8 

Atoms to form Gamma 1  3  4    Bend direction   Pair atoms unit vector     Add Gamma 

        4    9 

Atoms to form Gamma 1  3  4    Bend direction   Pair atoms unit vector     Add Gamma 

        4    10 

Проверяем правильность ввода координат типа γ. 

View g 

Close View 

 

В этой модели мы впервые сталкиваемся с описанием внутренних вращений. Одно из 

нормальных колебаний модели состоит во вращении метильных групп друг относительно 

друга вокруг оси симметрии модели. Хорошо бы иметь для описания такого движения 
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колебательную координату специального вида. Однако в нашем арсенале такой 

колебательной координаты нет. Приходится прибегать к искусственному приему. Введем 

три неплоских координаты типа χ с помощью следующих команд. 

 

Angle coords -> Add His 

Plane 1 with atoms…turns around  against   Plane 1 with atoms…turning around     Add Hi 

 5   2   1           pair atoms unit vector    8  4  3     pair atoms unit vector 

   1    2      2   1      

Plane 1 with atoms…turns around  against   Plane 1 with atoms…turning around     Add Hi 

 6   2   1           pair atoms unit vector     9  4  3     pair atoms unit vector 

   1    2      2   1      

Plane 1 with atoms…turns around  against   Plane 1 with atoms…turning around     Add Hi 

 7   2   1           pair atoms unit vector   10  4  3     pair atoms unit vector 

   1    2      2   1      

Проверяем правильность ввода координат типа χ.  

View h 

Close View 

 

File -> Save 

File -> txt-files for calculations 

 

File -> Exit 

 

simlev.exe 

 

Все в порядке. Файл Errors.txt пустой. Его можно удалить, чтобы не раздражал. В файле 

Symmetry.txt видно, что правильно распозналась группа симметрии D3d, причем к системе 

колебательных координат нет никаких претензий. Можно работать дальше. 

 

Далее приходим к вводу силовых постоянных модели диметилацетилена, обратившись к 

программе Umiu.m. С вводом электрооптических параметров пока повременим. 

 

File -> New Umiu for  

Естественно, для модели диметилацетилена.  

File -> Exit 

 

В папке DiMeAcML возник файл Umiu.mat и текстовый файл u_list.txt с нулевыми 

значениями силовых и электрооптических параметров. Этот файл надо сохранить под 

именем ulist.txt и внести в него значения силовых параметров из таблицы книги [1], 

страница 45.  Там приведено всего лишь 8 характерных силовых постоянных. Их и вводим 

в файл ulist.txt: 

 

   1    1   8.28  0.0000   0.0000   0.0000 qq     1    2  

   1    2   0.29      NaN   0.0000   0.0000 qq     1    2 /     3    1  

   1    4   0.09     NaN   0.0000   0.0000 qq     1    2 /     2    5  

   1   10   0.52      NaN   0.0000   0.0000 qa     1    2 /     1    2    5  

   1   13   0.0000      NaN   0.0000   0.0000 qa     1    2 /     5    2    7  

   2    2   24.3   0.0000   0.0000   0.0000 qq     3    1  

   4    4   0.0000   0.0000   0.0000   0.0000 qq     2    5  

   4    5   0.0000      NaN   0.0000   0.0000 qq     2    5 /     2    6  

   4   10   0.0000      NaN   0.0000   0.0000 qa     2    5 /     1    2    5  

   4   11   0.0000      NaN   0.0000   0.0000 qa     2    5 /     1    2    6  
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   4   13   0.0000      NaN   0.0000   0.0000 qa     2    5 /     5    2    7  

   4   15   0.0000      NaN   0.0000   0.0000 qa     2    5 /     6    2    7  

   4   22   0.0000      NaN   0.0000   0.0000 qg     2    5 /     2    1    3  

   4   23   0.0000      NaN   0.0000   0.0000 qg     2    5 /     2    1    3  

   4   29   0.0000      NaN   0.0000   0.0000 qh     2    5 /     6    2    1    9    4    3  

  10   10   0.0000      NaN      NaN      NaN aa     1    2    5  

  10   11   0.0000      NaN      NaN      NaN aa     1    2    5 /     1    2    6  

  10   13   0.0000      NaN      NaN      NaN aa     1    2    5 /     5    2    7  

  10   15   0.0000      NaN      NaN      NaN aa     1    2    5 /     6    2    7  

  10   22   0.0000      NaN      NaN      NaN ag     1    2    5 /     2    1    3  

  10   23   0.0000      NaN      NaN      NaN ag     1    2    5 /     2    1    3  

  10   25   0.0000      NaN      NaN      NaN ag     1    2    5 /     1    3    4  

  10   26   0.0000      NaN      NaN      NaN ag     1    2    5 /     1    3    4  

  10   29   0.0000      NaN      NaN      NaN ah     1    2    5 /     6    2    1    9    4    3  

  13   13   0.0000      NaN      NaN      NaN aa     5    2    7  

  13   14   0.0000      NaN      NaN      NaN aa     5    2    7 /     5    2    6  

  13   22   0.0000      NaN      NaN      NaN ag     5    2    7 /     2    1    3  

  13   23   0.0000      NaN      NaN      NaN ag     5    2    7 /     2    1    3  

  13   28   0.0000      NaN      NaN      NaN ah     5    2    7 /     5    2    1    8    4    3  

  22   22   0.29      NaN      NaN      NaN gg     2    1    3  

  22   23   0.0000      NaN      NaN      NaN gg     2    1    3 /     2    1    3  

  22   25   -0.12      NaN      NaN      NaN gg     2    1    3 /     1    3    4  

  22   26   0.0000      NaN      NaN      NaN gg     2    1    3 /     1    3    4  

  22   29   0.0000      NaN      NaN      NaN gh     2    1    3 /     6    2    1    9    4    3  

  28   28   0.04      NaN      NaN      NaN hh     5    2    1    8    4    3  

  28   29   0.0000      NaN      NaN      NaN hh     5    2    1    8    4    3 /     6    2    1    9    4    3 

Пока не удаляем ни из этого файла, ни из списка, который должен возникнуть в панели 

Umiu, строчек с нулевыми значениями всех параметров. Такие строчки могут 

понадобиться для ввода электрооптических параметров, которыми мы пока не 

занимаемся. 

 

После сохранения отредактированного файла ulist.txt снова вызываем панель Umiu. 

 

File -> Open Bstuct-Umiu for 

Естественно, для модели диметилацетилена.  

Edit U-Miu -> Input ulist.txt with corrections 

File -> Save Umiu.mat 

 

Команду File -> Save Usparse.txt давать рано, поскольку многие силовые постоянные, даже 

диагональные, еще не определены. Источник нам советует «Остальные элементы матрицы 

U, как в метилацетилене».  

 

Следуя этому совету, используем новую команду панели Umiu: 

 

Edit U-Miu -> Import U-Miu of model… 

 

В открывшемся диалоговом окне находим папку MeAcetileneML и открываем файл 

Umiu.mat этой модели. Этот файл будет служить источником параметров, относящихся к 

геометрически одинаковым взаимодействиям колебательных координат в моделях 

диметилацетилена и метилацетилена. 
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В списке параметров на панели Umiu появляются новые значения, которых мы не вводили 

в модель диметилацетилена. Эти значения импортированы из модели метилацетилена. 

Для знакомства с полным списком силовых постоянных в обновленной модели 

диметилацетилена выполняем команды 

 

File -> Save Umiu.mat 

File -> Save Usparse.txt 

File -> Exit 

 

Давать команду File -> Save Miu.txt dmdqSparse.txt еще не время, поскольку  мы не введи в 

модель электрооптические параметры. 

 

Новое состояние модели в части ее силовых постоянных отражено в файлах u_list.txt и 

Uqsparse.txt. Можно убедиться, что, как минимум, все диагональные силовые постоянные 

встали на свои места. Без этого расчет частот колебаний невозможен. Впрочем, проверку 

этого факта лучше поручить программе MatrixU. Она даст сообщение об ошибке, если не 

обнаружит какую-то из диагональных силовых постоянных в файле Uqsparse.txt. 

 

Выполняем расчет частот колебаний с помощью последовательности команд: 

MatrixT 

diag1 

MatrixU 

diag2 

 

Получим файл freqs.txt: 

     1156.82     1383.72     2923.872      710.88  

     1383.16     2266.12     2923.93      208.85  

     1035.60     1474.75     2976.12      208.82  

     1035.54     1474.81     2976.08      371.43  

     1023.90     1448.72     2975.74      371.40  

     1023.83     1448.78     2975.71      299.45 

 

Сравниваем с частотами, приведенными в источнике. Наивысшие частоты получились 

точно. Это понятно – они не зависят от длин связей в группе CH3.  Остальные частоты 

отличаются не более, чем на 7 см
-1

. Это результат того, что мы изменили длину связи в 

группе CH3. А силовые постоянные мы не подправляли. При желании это можно сделать, 

причем у нас имеется алгоритм, который справляется с этой задачей автоматически. Но не 

будем этим заниматься. Сейчас полученная точность подтверждает правильность ввода 

тех силовых постоянных, которые мы безо всякого труда позаимствовали у модели 

метилацетилена. Трудилась программа, распознавая геометрически эквивалентные 

фрагменты двух моделей, и расставляя соответствующие параметры на нужные места. Как 

я ее обучал. Оказалось, что это проще, чем обучить тому же самому лаборанта. Будем 

двигаться дальше. 

 

Введем в модель диметилацетилена электрооптические параметры и рассчитаем 

интенсивности в ИК спектре модели. Значения параметров мы найдем в указанном выше 

источнике на странице 48. Мы позаботились, чтобы нумерация всех колебательных 

координат у нас совпадала с нумерацией источника. Поэтому перенос значений 

параметров из литературного источника в файл ulist.txt не составит труда. Надо только 

учесть, что сейчас файл ulist.txt содержит устаревшую информацию, касающуюся тех 8 

характерных силовых постоянных, которые присущи собственно диметилацетилену. Нам 

нужен новый файл ulist.txt. Получим его так.  



27 
 

Откроем обновленный программой Umiu файл u_list.txt со всеми силовыми параметрами 

модели. Сохраним его под именем ulist.txt. Вот этот новый файл ulist.txt мы и будем 

править, пока он не приобретет такой вид: 

1 1 8.28 0 0.09 NaN  qq     1    2  

 1 2 0.29 NaN 0 0  qq     1    2 /     3    1  

 1 4 0.09 NaN 0 0  qq     1    2 /     2    5  

 1 10 0.52 NaN 0 0  qa     1    2 /     1    2    5  

 1 13 0.000000 NaN 0.000000 NaN qa     1    2 /     5    2    7  

 2 2 24.3 0 0 0  qq     3    1  

 4 4 8.14 0.305 0.71 NaN  qq     2    5  

 4 5 0.1 NaN 0.28 NaN qq     2    5 /     2    6  

 4 10 0.35 NaN -0.24 NaN  qa     2    5 /     1    2    5  

 4 11 0.000000 NaN -0.56 NaN qa     2    5 /     1    2    6  

 4 13 0.38 NaN -0.27 NaN  qa     2    5 /     5    2    7  

 4 15 0.000000 NaN -0.28 NaN qa     2    5 /     6    2    7  

 4 22 0.000000 NaN 0.000000 0.000000 qg     2    5 /     2    1    3  

 4 23 0.000000 NaN 0.000000 0.000000 qg     2    5 /     2    1    3  

 4 29 0.000000 NaN 0.000000 0.000000 qh     2    5 /     6    2    1    9    4    3  

 10 10 0.92 NaN NaN NaN  aa     1    2    5  

 10 11 -0.025 NaN NaN NaN  aa     1    2    5 /     1    2    6  

 10 13 -0.034 NaN NaN NaN  aa     1    2    5 /     5    2    7  

 10 15 0.000000 NaN NaN NaN aa     1    2    5 /     6    2    7  

 10 22 0.000000 NaN NaN NaN ag     1    2    5 /     2    1    3  

 10 23 0.000000 NaN NaN NaN ag     1    2    5 /     2    1    3  

 10 25 0.000000 NaN NaN NaN ag     1    2    5 /     1    3    4  

 10 26 0.000000 NaN NaN NaN ag     1    2    5 /     1    3    4  

 10 29 0.000000 NaN NaN NaN ah     1    2    5 /     6    2    1    9    4    3  

 13 13 0.71 NaN NaN NaN  aa     5    2    7  

 13 14 -0.025 NaN NaN NaN  aa     5    2    7 /     5    2    6  

 13 22 0.000000 NaN NaN NaN ag     5    2    7 /     2    1    3  

 13 23 0.000000 NaN NaN NaN ag     5    2    7 /     2    1    3  

 13 28 0.000000 NaN NaN NaN ah     5    2    7 /     5    2    1    8    4    3  

 22 22 0.29 NaN NaN NaN  gg     2    1    3  

 22 23 0.000000 NaN NaN NaN gg     2    1    3 /     2    1    3  

 22 25 -0.120000 NaN NaN NaN gg     2    1    3 /     1    3    4  

 22 26 0.000000 NaN NaN NaN gg     2    1    3 /     1    3    4  

 22 29 0.000000 NaN NaN NaN gh     2    1    3 /     6    2    1    9    4    3  

 28 28 0.040000 NaN NaN NaN hh     5    2    1    8    4    3  

 28 29 0.000000 NaN NaN NaN hh     5    2    1    8    4    3 /     6    2    1    9    4    3 

 

Изменились только те строки файла, которые относятся к координатам растяжения связей. 

Туда введены дипольные моменты связей в группе CH3 и производные от дипольных 

моментов по ближним колебательным координатам. 

 

Введем все эти параметры в модель, обратившись к программе Umiu.m. Силовые 

постоянные введутся снова, но это ничего не испортит, поскольку будут заново введены 

уже апробированные параметры. А характерные электрооптические параметры займут 

положенные им места и в файле Umiu.mat, и в текстовых файлах.  

 

File -> Open Bstuct-Umiu for 

Естественно, для модели диметилацетилена.  

Edit U-Miu -> Input ulist.txt with corrections 
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File -> Save Umiu.mat 

File -> Save Usparse.txt 

File -> Save Miu.txt dmdqSparse.txt 

File -> Exit 

 

intir 

  

Проверяем, правильно ли получились интенсивности. Правильно. Вводим 

рекомендованные в источнике полуширины полос поглощения в файл sigma.txt. Ниже 

приведены все полученные в нашем расчете результаты. 

 

Frequency Inencity sigma 

1/cm abs unit 1/cm 

1156.818 0.12 15 

1383.719 1.36 10 

2923.871 22.08 20 

710.8751 0 10 

1383.155 0 10 

2266.128 0 10 

2923.928 0 10 

208.8475 0.22 15 

1035.603 0.29 15 

1474.745 7.3 18 

2976.116 10.18 20 

208.8183 0.22 15 

1035.536 0.29 15 

1474.812 7.3 18 

2976.078 10.18 20 

371.429 0 10 

1023.897 0 10 

1448.719 0 10 

2975.744 0 10 

371.3979 0 10 

1023.834 0 10 

1448.782 0 10 

2975.706 0 10 

299.4472 0 10 

 

IRcurve 

 

Получаем кривую спектрального распределения ИК поглощения для модели 

диметилацетилена. 
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Картина не впечатляет. Здесь сказывается сравнительно высокая симметрия модели. 

Симметрия – красивая вещь, особенно в искусстве. Однако в физике она частенько играет 

предательскую роль. А именно, скрывает от наблюдателя большую часть физических 

проявлений наблюдаемого объекта. Вот у нас получились скрытыми от ИК спектрометров 

многие колебания нашей модели. Это явление может быть систематически изучено с 

помощью аппарата теории групп. Можно вывести для различных точечных групп 

симметрии так называемые правила отбора, которые позволяют прогнозировать, какие 

частоты в спектре окажутся невидимыми. Довольно тяжелый аппарат для изучения и 

усвоения. На мой взгляд, проще получить эти прогнозы в расчете для конкретной модели, 

как мы и сделали. 

 

Еще одно физическое замечание. Мы ввели координаты внутреннего кручения для 

метильных групп. Получили единственную частоту такого крутильного колебания 299.45 

см-1. Она по правилам отбора не активна в ИК спектре. Так ради чего старались? Раз это 

нормальное колебание выделяется в отдельный блок симметрии, значит, соответствующие 

колебательные координаты не взаимодействуют ни с какими другими координатами. 

Значит, мы могли бы не вводить этих сложных координат. И для остальных нормальных 

колебаний частоты никак не изменились бы. Так мы часто и поступаем ради упрощения 

моделей. Ведь физики – жуткие упрощенцы. Тем и сильны. 

 

С другой стороны, теория колебаний молекул это не только теория ИК спектров. Это 

значительно более общая теория, поскольку колебание ядер в молекулах является чуть ли 

не самым главным видом механического движения в веществе. И очень многие свойства 

вещества можно прогнозировать, зная частоты и формы колебаний молекул. Пусть кому-

то из инженеров-химиков понадобились термодинамические функции диметилацетилена. 

Без этих функций невозможно спроектировать работу химического реактора. Из 

статистической физики известно, что все термодинамические функции вещества 

выражаются через так называемые статсуммы. Так вот, главный вклад в статсумму дают 

самые низкие частоты колебаний молекулы вещества. И если в этом расчете потерять 
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частоту крутильных колебаний, то значения термодинамических свойств этого вещества 

не удастся получить правильными. 

 

Кстати, это красивое движение, затрагивающее только протоны метильных групп, можно 

наблюдать с помощью программы MolView/ У нас все для этого уже готово. 

 

Теперь нам надо рассчитать интенсивности в ИК спектре метилацетилена. Снова 

вызываем панель Umiu. 

 

File -> Open Bstuct-Umiu for 

Естественно, для модели метилацетилена.  

Edit U-Miu -> Import U-Miu of model… 

 

В открывшемся диалоговом окне находим папку DiMeAcML и открываем файл Umiu.mat 

этой модели. Этот файл будет служить источником параметров, относящихся к 

геометрически одинаковым взаимодействиям колебательных координат в моделях 

диметилацетилена и метилацетилена. Мы хотим, по рекомендации литературного 

источника, автоматически позаимствовать электрооптические параметры из родственной 

модели. Конечно, будут заимствованы все параметры, но это не должно испортить модель 

метилацетилена. Проверим. 

 

File -> Save Umiu.mat 

File -> Exit 

 

Обновились файлы Umiu.mat и u_list.txt. Сохраняем файл u_list.txt под именем ulist.txt. 

Будем его просматривать и править. Сейчас файл выглядит так: 

 

1 1 24.3 0 0 0  qq     1    2  

 1 2 0.29 NaN 0 0  qq     1    2 /     2    3  

 1 3 0.300000 NaN 0.000000 0.000000 qq     1    2 /     1    4  

 2 2 8.28 0 0.09 NaN  qq     2    3  

 2 4 0.09 NaN 0 0  qq     2    3 /     3    5  

 2 7 0.52 NaN 0 NaN  qa     2    3 /     2    3    5  

 2 10 0.000000 NaN 0.000000 0.000000 qa     2    3 /     5    3    6  

 3 3 9.972000 0.000000 0.000000 0.000000 qq     1    4  

 4 4 8.14 0.305 0.71 NaN  qq     3    5  

 4 5 0.1 NaN 0.28 NaN  qq     3    5 /     3    6  

 4 7 0.35 NaN -0.24 NaN  qa     3    5 /     2    3    5  

 4 8 0 NaN -0.56 NaN  qa     3    5 /     2    3    6  

 4 10 0.38 NaN -0.27 NaN  qa     3    5 /     5    3    6  

 4 12 0 NaN -0.28 NaN  qa     3    5 /     6    3    7  

 4 13 0.000000 NaN 0.000000 0.000000 qg     3    5 /     1    2    3  

 4 14 0.000000 NaN 0.000000 0.000000 qg     3    5 /     1    2    3  

 7 7 0.92 NaN NaN NaN  aa     2    3    5  

 7 8 -0.025 NaN NaN NaN  aa     2    3    5 /     2    3    6  

 7 10 -0.034 NaN NaN NaN  aa     2    3    5 /     5    3    6  

 7 12 0.000000 NaN NaN NaN aa     2    3    5 /     6    3    7  

 7 13 0.000000 NaN NaN NaN ag     2    3    5 /     1    2    3  

 7 14 0.000000 NaN NaN NaN ag     2    3    5 /     1    2    3  

 7 16 0.100000 NaN NaN NaN ag     2    3    5 /     2    1    4  

 7 17 0.000000 NaN NaN NaN ag     2    3    5 /     2    1    4  

 10 10 0.71 NaN NaN NaN  aa     5    3    6  
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 10 11 -0.025 NaN NaN NaN  aa     5    3    6 /     5    3    7  

 10 13 0.000000 NaN NaN NaN ag     5    3    6 /     1    2    3  

 10 15 0.000000 NaN NaN NaN ag     5    3    6 /     1    2    3  

 13 13 0.29 NaN NaN NaN  gg     1    2    3  

 13 14 0.000000 NaN NaN NaN gg     1    2    3 /     1    2    3  

 13 16 0.120000 NaN NaN NaN gg     1    2    3 /     2    1    4  

 13 17 0.000000 NaN NaN NaN gg     1    2    3 /     2    1    4  

 16 16 0.230000 NaN NaN NaN gg     2    1    4  

 16 17 0.000000 NaN NaN NaN gg     2    1    4 /     2    1    4 

 

Да, силовые постоянные не испортились. Нам повезло, что мы никак не корректировали 

силовые постоянные, попавшие из метилацетилена в диметилацетилен. Сейчас мы их 

получили назад в неизменном виде. Но если бы мы захотели улучшить расчет 

диметилацетилена путем коррекции силового поля, то сейчас мы могли бы испортить 

модель метилацетилена. Так что требуется внимание при выполнении операции импорта 

параметров из родственной модели. 

 

Обращаем внимание на электрооптические параметры в новом файле ulist.txt. Раньше их 

там не было вообще. Сейчас они там появились. Можно убедиться, что они встали на свои 

законные места в строках, касающихся метильной группы метилацетилена. Но не все они 

удовлетворили авторов модели. Такие заимствованные параметры были уточнены 

авторами путем решения обратной электрооптической задачи. Кроме того, в модель были 

введены специфические характерные электрооптические параметры. Если мы хотим 

полностью повторить литературные данные по этой модели, нам придется править 

некоторые значения в файле ulist.txt. Вот что получится: 

 

1 1 24.3 -0.9 -0.2 NaN  qq     1    2  

 1 2 0.29 NaN 0 0  qq     1    2 /     2    3  

 1 3 0.300000 NaN 0.000000 0.000000 qq     1    2 /     1    4  

 2 2 8.28 0.4 0.5 NaN  qq     2    3  

 2 4 0.09 NaN 0 0  qq     2    3 /     3    5  

 2 7 0.52 NaN 0 NaN  qa     2    3 /     2    3    5  

 2 10 0.000000 NaN 0.000000 0.000000 qa     2    3 /     5    3    6  

 3 3 9.972000 1.0 0.892 NaN qq     1    4  

 4 4 8.14 0.28 0.71 NaN  qq     3    5  

 4 5 0.1 NaN 0.28 NaN  qq     3    5 /     3    6  

 4 7 0.35 NaN -0.24 NaN  qa     3    5 /     2    3    5  

 4 8 0 NaN -0.56 NaN  qa     3    5 /     2    3    6  

 4 10 0.38 NaN -0.27 NaN  qa     3    5 /     5    3    6  

 4 12 0 NaN -0.28 NaN  qa     3    5 /     6    3    7  

 4 13 0.000000 NaN 0.000000 0.000000 qg     3    5 /     1    2    3  

 4 14 0.000000 NaN 0.000000 0.000000 qg     3    5 /     1    2    3  

 7 7 0.92 NaN NaN NaN  aa     2    3    5  

 7 8 -0.025 NaN NaN NaN  aa     2    3    5 /     2    3    6  

 7 10 -0.034 NaN NaN NaN  aa     2    3    5 /     5    3    6  

 7 12 0.000000 NaN NaN NaN aa     2    3    5 /     6    3    7  

 7 13 0.000000 NaN NaN NaN ag     2    3    5 /     1    2    3  

 7 14 0.000000 NaN NaN NaN ag     2    3    5 /     1    2    3  

 7 16 0.100000 NaN NaN NaN ag     2    3    5 /     2    1    4  

 7 17 0.000000 NaN NaN NaN ag     2    3    5 /     2    1    4  

 10 10 0.71 NaN NaN NaN  aa     5    3    6  

 10 11 -0.025 NaN NaN NaN  aa     5    3    6 /     5    3    7  



32 
 

 10 13 0.000000 NaN NaN NaN ag     5    3    6 /     1    2    3  

 10 15 0.000000 NaN NaN NaN ag     5    3    6 /     1    2    3  

 13 13 0.29 NaN NaN NaN  gg     1    2    3  

 13 14 0.000000 NaN NaN NaN gg     1    2    3 /     1    2    3  

 13 16 0.120000 NaN NaN NaN gg     1    2    3 /     2    1    4  

 13 17 0.000000 NaN NaN NaN gg     1    2    3 /     2    1    4  

 16 16 0.230000 NaN NaN NaN gg     2    1    4  

 16 17 0.000000 NaN NaN NaN gg     2    1    4 /     2    1    4 

 

Сохраняем откорректированный файл и выполняем в панели Umiu команды: 

 

File -> Open Bstuct-Umiu for 

Естественно, для модели метилацетилена.  

Edit U-Miu -> Input ulist.txt with corrections 

File -> Save Umiu.mat 

File -> Save Miu.txt dmdqSparse.txt 

File -> Exit 

 

Затем выполняем расчет интенсивностей 

 

intir 

 

Проверяем расчетные интенсивности, вводим рекомендуемые полуширины в файл 

sigma.txt. Ниже приведены все полученные в нашем расчете результаты. 

 

Frequency Intencity sigma 

1/cm abs units 1/cm 

926.954661 0.36 12 

1383.336145 0.16 25 

2136.757129 2.13 8 

2923.897359 10.31 25 

3330.144103 15.71 25 

313.651479 4.1 15 

641.100718 17.26 15 

1044.45867 0.04 10 

1450.80234 2.92 12 

2975.855019 4.61 25 

313.639149 4.1 15 

641.090508 17.26 15 

1044.416998 0.04 10 

1450.90374 2.92 12 

2975.865934 4.61 25 

 

IRcurve 

 

Получаем кривую спектрального распределения ИК поглощения для модели 

метилацетилена. 
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Значительно более богатый спектр, чем у диметилацетилена, поскольку симметрия этой 

модели ниже. Она не обладает центром симметрии. 

 

Итак, мы без особого труда справились с задачей построения двух родственных моделей, 

которые занимали друг у друга параметры. Главной облегчение, что нам не пришлось 

следить за нумерацией колебательных координат в двух различных списках этих 

координат. Программа справлялась с этим совершенно самостоятельно. 

 

5.4. Как использовать фрагменты готовых моделей  
 

В идеале хорошо бы иметь следующую возможность. 

Мы потратили много сил и времени на отладку моделей различных органических 

соединений путем решения обратных спектральных задач. В результате имеется набор 

моделей, удовлетворяющих нашим противоречивым требованиям – а) модели прилично 

воспроизводят в расчете экспериментальные спектры, б) их параметры можно с успехом 

переносить из модели в модель вместе повторяющимися в моделях атомными 

группировками. Изобразим такой набор моделей в виде схемы, где приведены только две 

модели. 

A-X(B)-Y(C)-X(A)-B,  C-U-X(D)-D 

A, B, C, D – «концевые» атомные группировки. U, X, Y – «скелетные» атомные 

группировки. 

Теперь мы можем сформировать огромный набор новых достаточно надежных моделей 

очень сложных соединений. Их размеры и степень сложности ничем не ограничены, как 
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вообще не ограничена сложность и разнообразие мира органических соединений. Не 

будем решать полную комбинаторную задачу для фрагментов (атомных группировок) 

наших двух исходных апробированных моделей. Приведем лишь два примера структур, 

которые можно получить. 

A-[X(A)]n-A – структура типа линейного полимера с боковыми группами. И сразу можно 

приступать к вычислительным экспериментам, в результатах которых заинтересованы 

технологи – будет ли проявляться в ИК спектрах признак длины полимерной цепи.  

| |

| |

, ,

U - -X -A

(X -A)- -U
n m k

– структура типа молекулярного кристалла. И сразу можно 

приступать к вычислительным экспериментам, в результатах которых заинтересованы 

производители наночастиц– будут ли проявляться в далеких областях ИК спектра  

признаки размеров и формы молекулярных нанокристаллитов. 

В рассматриваемой идеальной ситуации нам не придется заботиться о геометрии, о 

системе внутренних колебательных координат фрагментов, о силовых и 

электрооптических параметрах. Вся эта параметризация даже таких сложных моделей, как  

полимеры и молекулярные кристаллы, нас уже не должна занимать. 

Однако, даже в такой идеальной ситуации далеко не всѐ так идеально просто. Обратим 

внимание на черточки в условных обозначениях всех наших гипотетических моделей. За 

каждой черточкой скрывается колебательная координата типа q. Вдруг нам понадобится 

комбинация фрагментов X-C. Такая комбинация в исходном наборе моделей не изучена. 

Мы не знаем значения силовой постоянной для такой колебательной координаты. Что 

делать? Это станет ясно, когда мы поработаем с реальными моделями, используя технику 

так называемого фрагментного формирования моделей. 

Вырезать фрагменты из готовых моделей или готовить их специально? 
 

Это трудный вопрос, на который каждый исследователь должен дать сам себе ответ. Мы, 

в группе Л.А. Грибова, решили для себя так.  

Если нам нужна центральная часть очень крупной молекулы, к которой нам предстоит в 

вычислительных экспериментах присоединять заранее заготовленные периферийные 

группировки, то наилучшие результаты мы получим, вырезав эту центральную часть 

апробированной модели. Тогда большая часть колебательных координат любой новой 

модели из изучаемой серии будет снабжена адекватными эмпирическими (силовыми и 

электрооптическими) параметрами. Тогда останется только отслеживать те возмущения, 

которые возникают в модели из-за влияния новых периферийных групп, а также влияния 

центральной части на новую периферию моделей. При этом, конечно, можно столкнуться 

с некой неопределенностью, связанной с неизвестными эмпирическими параметрами на 

стыках фрагментов (это параметры координат растяжения возникших новых валентных 

связей и параметры взаимодействий этих связей с ближайшими координатами 

центральной части и периферии). Но в случае очень массивной центральной части такая 

неопределенность не может привести к большим погрешностям в расчете в силу принципа 
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близкодействия, который прекрасно выполняется для органических соединений с не 

слишком протяженной системой сопряженных связей. 

Если нам надо получить модели небольших молекул, состоящих из хорошо изученных 

атомных группировок, то целесообразно приготовить заранее эти группировки в таком 

виде, который может и не соответствовать реальным молекулам, но зато описывает все 

стыковочные связи так, как мы хотим их видеть в новых моделях реальных соединений. 

Стыковочные связи и прилегающие к ним координаты лучше всего снабдить 

параметрами, полученными в результате решения обратных задач. Тогда можно 

надеяться, что сформированные из сравнительно малых фрагментов новые модели в 

расчете дадут очень удовлетворительные результаты. 

 

Такой ответ, который когда-то мы дали сами себе, во многом нас удовлетворял, позволив 

нам набрать значительную статистику удачных расчетов, выполненных с использованием 

фрагментов. Но теперь мы знаем, что этот ответ все же нельзя считать профессиональным. 

Теперь мы знаем, как выглядит профессиональный ответ. Вот он. 

 

Как и любой эксперимент в физике или химии, вычислительный эксперимент с моделями 

молекул должен опираться на некую методику. В норме эту методику находит и 

отлаживает сам исследователь, а уж затем он проводит серию экспериментов. На этапе 

разработки методики он уже заранее определяет те погрешности, которые будут 

характеризовать ожидаемые экспериментальные результаты. 

В главе 4 мы познакомились с универсальной процедурой оценки точности прогноза 

спектральных проявлений молекулярной модели. Эта процедура, примененная к моделям, 

построенным из фрагментов, и должна дать ответ на поставленный выше вопрос. 

Особенность ее применения к таким моделям состоит в том, что можно отделить 

погрешности прогноза, связанные со статистическими свойствами параметров 

фрагментов, от погрешностей, связанных только с неопределенностью параметров на 

стыках фрагментов. В этой процедуре надо всего лишь задать предполагаемые 

среднеквадратичные отклонения для неодоопределенных параметров, а остальные 

параметры временно считать точными. При этом не очень важно, что мы будем считать 

неизвестные нам систематические ошибки параметров случайными и применять к ним 

процедуру бутстрепа. Мы получим информацию, на какие спектральные признаки модели 

влияют эти стыковочные участки модели, и как они влияют. Это и позволит найти 

оптимальный способ разделения моделей на фрагменты и их использования при 

формировании новых моделей. 
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Как приготовить модель молекулы пропилена, имея в наличии модели 

молекул этилена и этана? 

 

Рисунок модели пропилена. Такой мы хотели бы видеть эту модель в окне программы 

MolView. 

Все три упомянутых модели очень малы. Вырезать из них сразу готовые фрагменты 

пропилена не удастся. Будем готовить два необходимых фрагмента специально, не 

смущаясь тем, что проще было бы сразу приготовить модель пропилена известными нам 

уже способами. На маленьком примере легче показать всю методику фрагментного 

расчета. С более крупными моделями и фрагментами мы будем действовать так же, но с 

более заметным толком и с большей экономией сил и времени. 

Условимся также, что мы не будем стремиться сразу получить ту модель пропилена, 

которая приведена в книге [2], стр. 112. В этой стандартной модели пропилена сделано 

всѐ, что было известно о его геометрии из литературных источников, а силовые 

постоянные и электрооптические параметры найдены из решения обратных задач. 

Поэтому данная стандартная (оптимизированная) модель довольно сложна своим 

разнообразием длин всех связей CH. Мы сейчас будем строить упрощенную модель, не 

стремясь добиться от нее спектроскопической точности. Такие модели «нулевого 

приближения» полезны в некоторых вычислительных экспериментах, когда надо 

проследить за их проявлениями на качественном или полуколичественном уровне. А 

сейчас некоторое упрощение модели пропилена поможет нам осмотреть технику 

фрагментного расчета. 

Познакомимся с готовыми моделями и превратим их в нужные нам фрагменты. 
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Модель этилена находится в папке EthyleneML. Создадим папку FRAGM1 и скопируем 

туда из папки EthyleneML файлы Bstruct.mat и Umiu.mat. Пользуясь панелью Bstruct.m, 

откроем в папке FRAGM1 файл Bstruct.mat и получим картину 
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Для того, чтобы превратить эту модель во фрагмент пропилена, надо заменить атом H4 на 

C4 и удлинить связь C2-C4. Это легко выполнить с помощью команд панели Bstruct. Я не 

буду подробно записывать последовательность команд. Мы их освоили в главе 2. 

Систематическое описание команд можно найти в специальной главе с инструкциями ко 

всем программам. Теперь я буду писать только о необходимых операциях над моделями и 

приводить полученные результаты. 

Насколько надо удлинить связь C2-C4, можно узнать из книги [2], стр. 112. Ее длина 

должна быть 1.501 Å. Длина связи C2-H4 в исходной модели этилена равна 1.086 Å. 

Значит, заменив атом H4 на C4, затем надо передвинуть атом C4 вдоль связи C2-C4 на 

0.415 Å.  

View Bonds  

Видим новую картину: 
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Сделав это, не выходим пока из панели. У бывшей модели этилена есть одна особенность, 

которую надо обязательно учитывать при фрагментном расчете новых моделей. Это 

колебательная координата типа χ. Требуется, чтобы ось вращения для вращающейся 

плоскости в этой координате была задана не через координатный орт, а через временный 

единичный вектор, определяемый парой атомов. Иначе при вращении в пространстве 

фрагмента как целого, программы не смогут правильно построить координату этого типа, 

поскольку орт не будет вращаться вместе с фрагментом, а нужная пара атомов самого 

фрагмента будет послушно вращаться.  

К сожалению, панель не сохраняет наружных признаков того, как была введена такая 

координата. Этого нельзя выяснить и из файла BhStructures.txt. Приходится прибегать к 

искусственному приему, чтобы заглянуть в рабочую область MatLab. В командном окне 

выполним команду  

global His 

В рабочей области (Workspace) появляется массив His, содержимое которого можно 

просмотреть с помощью редактора массивов. Двойным щелчком мыши по пиктограмме 

массива, вызываем его в редактор массивов. Видим в окне Array Editor – His 

3 2 4 0 1 2 5 1 6 0 2 1 

Это полная информация для программ, как надо строить единственную координату типа χ 

в данной модели. Ноль в группе чисел для первой плоскости говорит о том, что готовый 

орт не используется. Иначе здесь стоял бы номер этого орта. Номера 1 2 говорят о том, 
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что первую плоскость надо вращать вокруг оси, определяемой этими атомами. Ось 

направлена от 1 к 2. Вторую плоскость надо вращать вокруг оси 2 1. Всѐ в порядке. 

File -> Save 

File -> txt-files for calculations 

File -> Exit 

В командном окне вводим clear global. Пиктограмма массива His исчезнет из окна 

рабочей области MatLab. 

Не имеет смысла анализировать симметрию модели с помощью программы symlev.exe, 

поскольку из всех элементов симметрии исходного этилена в модели FRAGM1 осталась 

только плоскость, в которой лежат все атомы модели. Программа symlev.exe могла бы 

только разделить совокупность колебательных координат на плоские и неплоские. Сейчас 

это не так уж интересно. Можете попробовать, если хотите. 

Дальше надо заняться параметрами u, μ, dμ/dq. Вызываем панель Umiu.m. Создаем новый 

файл Umiu.mat для модели FRAGM1 с помощью команды  

File -> New Umiu for… 

И сразу импортируем в этот файл параметры из модели этилена командой  

Edit -> Implrt U-Miu of model… 

Естественно, EthyleneML. 

File -> Save Umiu.mat 

File -> Exit 

Открыв файл u_list.txt, узнаем, что у нас получилось: 

1 1 14.2 0 0 0  qq     1    2  

 1 2 0.1 NaN 0 0  qq     1    2 /     2    3  

   1    3   0.0000      NaN   0.0000   0.0000 qq     1    2 /     2    4  

 1 6 0.42 NaN NaN NaN  qa     1    2 /     1    2    3  

   1    7   0.0000      NaN   0.0000   0.0000 qa     1    2 /     1    2    4  

   1   10   0.0000      NaN   0.0000   0.0000 qa     1    2 /     3    2    4  

   1   11   0.0000      NaN   0.0000   0.0000 qa     1    2 /     5    1    6  

 2 2 8.55 0.719 0.493 NaN  qq     2    3  

   2    3   0.0000      NaN   0.0000   0.0000 qq     2    3 /     2    4  

 2 6 0.2 NaN 0.481 NaN  qa     2    3 /     1    2    3  

   2    7   0.0000      NaN   0.0000   0.0000 qa     2    3 /     1    2    4  

   2    8   0.0000      NaN   0.0000   0.0000 qa     2    3 /     2    1    5  

   2    9   0.0000      NaN   0.0000   0.0000 qa     2    3 /     2    1    6  

   2   10   0.0000      NaN   0.0000   0.0000 qa     2    3 /     3    2    4  

   3    3   0.0000   0.0000   0.0000   0.0000 qq     2    4  

   3    6   0.0000      NaN   0.0000   0.0000 qa     2    4 /     1    2    3  

   3    7   0.0000      NaN   0.0000   0.0000 qa     2    4 /     1    2    4  

   3    8   0.0000      NaN   0.0000   0.0000 qa     2    4 /     2    1    5  

   3    9   0.0000      NaN   0.0000   0.0000 qa     2    4 /     2    1    6  

   3   10   0.0000      NaN   0.0000   0.0000 qa     2    4 /     3    2    4  

 4 5 0.03 NaN 0.041 NaN  qq     1    5 /     1    6  

   4    7   0.0000      NaN   0.0000   0.0000 qa     1    5 /     1    2    4  

   4    9   0.0000      NaN   0.0000   0.0000 qa     1    5 /     2    1    6  

 4 11 0.12 NaN 0.551 NaN  qa     1    5 /     5    1    6  

   5    7   0.0000      NaN   0.0000   0.0000 qa     1    6 /     1    2    4  

 6 6 0.77 NaN NaN NaN  aa     1    2    3  

   6    7   0.0000      NaN      NaN      NaN aa     1    2    3 /     1    2    4  

 6 8 -0.025 NaN NaN NaN  aa     1    2    3 /     2    1    5  



40 
 

 6 9 0.095 NaN NaN NaN  aa     1    2    3 /     2    1    6  

   6   10   0.0000      NaN      NaN      NaN aa     1    2    3 /     3    2    4  

   7    7   0.0000      NaN      NaN      NaN aa     1    2    4  

   7    8   0.0000      NaN      NaN      NaN aa     1    2    4 /     2    1    5  

   7    9   0.0000      NaN      NaN      NaN aa     1    2    4 /     2    1    6  

   7   10   0.0000      NaN      NaN      NaN aa     1    2    4 /     3    2    4  

   8    9   0.0000      NaN      NaN      NaN aa     2    1    5 /     2    1    6  

   8   10   0.0000      NaN      NaN      NaN aa     2    1    5 /     3    2    4  

   8   11   0.0000      NaN      NaN      NaN aa     2    1    5 /     5    1    6  

   9   10   0.0000      NaN      NaN      NaN aa     2    1    6 /     3    2    4  

  10   10   0.0000      NaN      NaN      NaN aa     3    2    4  

 11 11 0.57 NaN NaN NaN  aa     5    1    6  

  12   12   0.0000      NaN      NaN      NaN rr     3    2    4    1  

  12   13   0.0000      NaN      NaN      NaN rr     3    2    4    1 /     6    1    5    2  

  12   14   0.0000      NaN      NaN      NaN rh     3    2    4    1 /     3    2    4    5    1    6  

 13 13 0.35 NaN NaN NaN  rr     6    1    5    2  

  13   14   0.0000      NaN      NaN      NaN rh     6    1    5    2 /     3    2    4    5    1    6  

  14   14   0.0000      NaN      NaN      NaN hh     3    2    4    5    1    6 

 

Видно, что многие параметры из модели этилена перебрались в модель FRAGM1. Но 

некоторые параметры не нашлись. Это связано с тем, что изменились физические 

характеристики связи 2-4. Вместе с ними изменились характеристики и тех угловых и 

неплоских координат, в которые входят атомы 2 и 4. Поступим так. Припишем самой 

связи 2-4 те параметры, которые присущи оптимизированной модели пропилена, а для 

угловых и неплоских координат восстановим те параметры, которые были в модели 

этилена. Это не оптимальное решение, зато простое. Нам легко будет откорректировать 

файл u_list.txt, предварительно сохранив его под именем ulist.txt. 

Получится такой файл ulist.txt, который мы используем для корректировки файла 

Umiu.mat модели фрагмента. 

1 1 14.2 0 0 0  qq     1    2  

 1 2 0.1 NaN 0 0  qq     1    2 /     2    3  

   1    3   0.0000      NaN   0.0000   0.5 qq     1    2 /     2    4  

 1 6 0.42 NaN NaN NaN  qa     1    2 /     1    2    3  

   1    7   0.0000      NaN   0.0000   0.0000 qa     1    2 /     1    2    4  

   1   10   0.0000      NaN   0.0000   0.0000 qa     1    2 /     3    2    4  

   1   11   0.0000      NaN   0.0000   0.0000 qa     1    2 /     5    1    6  

 2 2 8.55 0.719 0.493 NaN  qq     2    3  

   2    3   0.21      NaN   -0.04   0.2 qq     2    3 /     2    4  

 2 6 0.2 NaN 0.481 NaN  qa     2    3 /     1    2    3  

   2    7   0.0000      NaN   0.0000   0.0000 qa     2    3 /     1    2    4  

   2    8   0.0000      NaN   0.0000   0.0000 qa     2    3 /     2    1    5  

   2    9   0.0000      NaN   0.0000   0.0000 qa     2    3 /     2    1    6  

   2   10   0.05      NaN   0.6   NaN qa     2    3 /     3    2    4  

   3    3   7.0   0.0   -0.3   NaN qq     2    4  

   3    6   0.0000      NaN   0.0000   0.0000 qa     2    4 /     1    2    3  

   3    7   0.415      NaN   0.05   NaN qa     2    4 /     1    2    4  

   3    8   0.0000      NaN   0.0000   0.0000 qa     2    4 /     2    1    5  

   3    9   0.0000      NaN   0.0000   0.0000 qa     2    4 /     2    1    6  

   3   10   0.0000      NaN   0.5   NaN qa     2    4 /     3    2    4  

 4 5 0.03 NaN 0.041 NaN  qq     1    5 /     1    6  

   4    7   0.0000      NaN   0.0000   0.0000 qa     1    5 /     1    2    4  

   4    9   0.0000      NaN   0.0000   0.0000 qa     1    5 /     2    1    6  

 4 11 0.12 NaN 0.551 NaN  qa     1    5 /     5    1    6  

   5    7   0.0000      NaN   0.0000   0.0000 qa     1    6 /     1    2    4  
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 6 6 0.77 NaN NaN NaN  aa     1    2    3  

   6    7   0.0000      NaN      NaN      NaN aa     1    2    3 /     1    2    4  

 6 8 -0.025 NaN NaN NaN  aa     1    2    3 /     2    1    5  

 6 9 0.095 NaN NaN NaN  aa     1    2    3 /     2    1    6  

   6   10   0.0000      NaN      NaN      NaN aa     1    2    3 /     3    2    4  

   7    7   0.77      NaN      NaN      NaN aa     1    2    4  

   7    8   -0.025      NaN      NaN      NaN aa     1    2    4 /     2    1    5  

   7    9   0.095      NaN      NaN      NaN aa     1    2    4 /     2    1    6  

   7   10   0.0000      NaN      NaN      NaN aa     1    2    4 /     3    2    4  

   8    9   0.0000      NaN      NaN      NaN aa     2    1    5 /     2    1    6  

   8   10   0.0000      NaN      NaN      NaN aa     2    1    5 /     3    2    4  

   8   11   0.0000      NaN      NaN      NaN aa     2    1    5 /     5    1    6  

   9   10   0.0000      NaN      NaN      NaN aa     2    1    6 /     3    2    4  

  10   10   0.57      NaN      NaN      NaN aa     3    2    4  

 11 11 0.57 NaN NaN NaN  aa     5    1    6  

  12   12   0.35      NaN      NaN      NaN rr     3    2    4    1  

  12   13   0.047      NaN      NaN      NaN rr     3    2    4    1 /     6    1    5    2  

  12   14   0.0000      NaN      NaN      NaN rh     3    2    4    1 /     3    2    4    5    1    6  

 13 13 0.35 NaN NaN NaN  rr     6    1    5    2  

  13   14   0.0000      NaN      NaN      NaN rh     6    1    5    2 /     3    2    4    5    1    6  

  14   14   0.755      NaN      NaN      NaN hh     3    2    4    5    1    6 

 

Проверим этот файл в работе. Введем его как коррекцию в панель Umiu.m, затем 

сформируем матрицы Tp и Uq, выполним обе диагонализации и рассчитаем 

интенсивности в гипотетическом ИК спектре модели, не соответствующей никакой 

действительности (три свободные валентности атома C4 ничем не заполнены). 

Получились такие результаты, дополненные произвольными полуширинами полос 

поглощения, чтобы рассчитать спектральную кривую. Любопытно сравнить эти 

результаты с данными по исходной модели этилена. 

  
FRAGM1 

   
Ethylene 

 

 
Frequency Intencity Sigma 

 
Frequency Intencity Sigma 

 
1/cm abs units 1/cm 

 
1/cm abs units 1/cm 

1 425.1759 0.43 10 1 1339.805 0 10 

2 587.2456 4.12 10 2 1620.96 0 10 

3 943.5239 0.27 10 3 3017.416 0 10 

4 947.5972 21.36 10 4 1246.768 0 10 

5 995.4538 4.29 10 5 3099.052 0 10 

6 1014.141 0.25 10 6 824.5844 0.32 8 

7 1295.459 0.81 10 7 3102.227 13.27 28 

8 1437.612 2.6 10 8 1444.36 5.1 16 

9 1667.018 1.66 10 9 3000.932 7.53 28 

10 3008.422 5.02 30 10 936.831 41.42 15 

11 3056.556 2.73 30 11 957.0519 0 10 

12 3099.74 6.24 30 12 1020.097 0 10 

 

Конечно, спектры получаются различными. 
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ИК спектр модели FRAGM1. 
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ИК спектр модели этилена. 

 

Да, спектры различаются. Однако в них можно найти очень похожие участки. Такое 

явление оказывается важным во всех приложениях молекулярной спектроскопии. Такие 

похожие спектральные признаки называются характеристическими. В книгах Л.А. 
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Грибова целые главы посвящены теории характеристических колебаний органических 

молекул. Мы не будем сейчас углубляться в теорию, но я советую понаблюдать нечто 

интересное. Вызовем на счет два экземпляра программы MolView. В одном экземпляре 

откроем модель FRAGM1, а в другом – модель этилена. Для обеих моделей будем 

наблюдать анимацию нормальных колебаний. И окажется, что некоторые участки в 

спектрах двух моделей неслучайно похожи.  

 

Нормальное колебание фрагмента с частотой 1295 по форме соответствует колебанию с 

частотой 1339 в этилене. Частота снизилась, поскольку в этом колебании фрагмента 

участвует значительно более массивный атом. Но колебание является характеристическим 

по форме. Обе частоты в ИК спектре неактивны. Таковы и крутильные колебания 955 и 

1020.  

Колебания с частотами 1437 и 1444 оказываются характеристическими и по частоте, и по 

форме, и по интенсивности. Такими же яркими свойствами обладают колебания с 

частотами 947 и 936.  А также и пара колебаний 3099 и 3102.  

 

Раз мы, даже испортив модель этилена, наблюдаем в его фантастическом фрагменте 

знакомые колебания, то мы можем смело прогнозировать – когда этот фрагмент будет 

включен в модель пропилена, эти характеристические признаки фрагмента не испортятся. 

На этой замечательной закономерности была в течение многих лет основана техника 

распознавания структур органических соединений по их ИК спектрам. Сейчас эта техника 

вытеснена ЯМР спектроскопией. Но в других приложениях анализ характеристических 

колебаний остается важным. Мы с этим будем знакомиться позже. 

 

Теперь, пользуясь описанной методикой, приготовим модель FRAGM2 из модели этана. 

Получится вот что: 
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Из исходной модели этана последовательно удалены атомы 8, 7 и 6. Атом 2 сдвинут в 

направлении вектора 2  1  на 0.042 Å. Таким способом мы сделали длину стыковочной 



44 
 

связи C1-C2 равной 1.501 Å, как в будущей модели пропилена. Больше ничего в 

геометрии и в системе колебательных координат фрагмента делать не надо.  

 

Часть силовых и электрооптических параметров мы импортируем из модели этана, но 

часть придется восстановить, поскольку длина связи C1-C2 изменилась. В результате 

получится такая система параметров. 

1 1 7.000000 0.000000 -0.300000 NaN qq     1    2  

 1 2 0.415000 NaN 0.050000 NaN qq     1    2 /     1    3  

 2 2 8.030000 0.305000 0.830000 NaN  qq     1    3  

 2 3 0.060000 NaN 0.280000 NaN  qq     1    3 /     1    4  

 2 5 0.300000 NaN -0.300000 NaN qa     1    3 /     2    1    3  

 2 8 0.300000 NaN -0.300000 NaN  qa     1    3 /     3    1    4  

 2 10 0.000000 NaN -0.380000 NaN  qa     1    3 /     4    1    5  

 5 5 0.920000 NaN NaN NaN aa     2    1    3  

 5 6 -0.025000 NaN NaN NaN aa     2    1    3 /     2    1    4  

 5 8 -0.034000 NaN NaN NaN aa     2    1    3 /     3    1    4  

 8 8 0.710000 NaN NaN NaN  aa     3    1    4  

 8 9 -0.034000 NaN NaN NaN  aa     3    1    4 /     3    1    5 

 

Для проверки правильности фрагмента выполним полный насчет частот и интенсивностей 

в его ИК спектре, включая анализ симметрии. Здесь также полезно понаблюдать за 

характеристичностью колебаний в моделях FRAGM2 и этана. 

 

Теперь мы готовы соединить два фрагмента и получить модель пропилена. Для этого надо 

воспользоваться программой JoinFragments.m. Но предварительно надо подготовить для 

этой программы исходные данные в виде файла ToJoin.txt, который надо поместить в 

папку Config системы LevInfinite. Вот как выглядит содержимое этого файла, куда наряду 

с данными помещены и подробные комментарии: 

 

Fragm1 Имя модели 1 

2   атом скелетный; он останется в скелете соединѐнной модели 

4  атом концевой; он будет отброшен 

2  атом 1 модели 1 для взаимной ориентации двух моделей 

3   атом 2 модели 1 для взаимной ориентации двух моделей 

Fragm2 Имя модели 2 

1  атом скелетный; он останется в скелете соединѐнной модели 

2  атом концевой; он будет отброшен 

1  атом 1 модели 2 для взаимной ориентации двух моделей 

3  атом 2 модели 2 для взаимной ориентации двух моделей 

Joint Имя новой соединѐнной модели 

 

Эти комментарии достаточны для рутиной работы, но не для ознакомления с логикой 

подготовки исходных данных для сложной программы.  Будем знакомиться с логикой 

постепенно. 

 

Мы хотим соединить два фрагмента в одну новую модель. В самом конце файла данных 

мы находим «Joint Имя новой соединѐнной модели». Пока мы не уверены, получится ли у 

нас модель, похожая на молекулу пропилена. Вдруг ее придется дорабатывать. Из 

осторожности назовем ее пока Joint – стык, соединение, сустав, если по-русски. 

Следовательно, надо приготовить пустую папку с именем Joint, куда программа поместит 

результаты стыковки фрагментов. Приготовили. 
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Теперь надо бы расположить рисунки наших двух фрагментов так, чтобы нам самим было 

предельно ясно, как мы хотим их соединить. Тут существенную помощь может оказать 

программа MolView. Откроем в этой программе модель FRAGM1. Уберем из окна 

программы всѐ лишнее ( w – walls, стенки комнаты;  h – hides, шкуры атомов). Включим 

нумерацию атомов (n – numbers). Получим картинку фрагмента 1. Откроем во втором 

экземпляре программы MolView модель FRAGM2. Из этого окна также уберем все, кроме 

номеров атомов. С помощью клавиш управления положением модели (стрелки, x, y, z, 

Shift) поставим модель фрагмента 2 в такое положение, какое он должен занимать в 

модели пропилена. На экране получатся две картинки, показанные ниже. 

 

Теперь попробуем прочесть, что сказано в исходных данных к программе. 

 

Fragm1 Имя модели 1 –  ясно, что программа должна ввести эту модель первой. 

2   атом скелетный; он останется в скелете соединѐнной модели –  понятно. 

4  атом концевой; он будет отброшен – скорее, не отброшен, а заменен атомом второго 

фрагмента. 

 

Пропустим пока две строки. 

Fragm2 Имя модели 2 –  ясно, что программа должна ввести эту модель второй. 

1  атом скелетный; он останется в скелете соединѐнной модели –  понятно. 

2  атом концевой; он будет отброшен – скорее, не отброшен, а заменен атомом первого 

фрагмента. 

 

Этой информации программе достаточно, чтобы правильно повернуть и переместить в 

пространстве фрагмент 2. У нас длины связи 2  4 первого и связи 1  2 второго фрагмента в 

точности одинаковы. Поэтому вся четверка атомов, упомянутая в рассмотренных 

строчках, встанет на нужные места. Лишние два атома, действительно, будут отброшены 

программой. 

 

 

  
 

 

 

Однако, это еще не все преобразования, связанные с положением фрагмента 2 в 

пространстве. Фрагмент может свободно вращаться вокруг стыковочной связи, а мы 
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хотим придать ему определенную ориентацию относительно фрагмента 1. Программа 

позволяет нам задать желательный угол между какими-то двумя связями двух 

фрагментов. Удачно, что нам необязательно знать точное значение этого угла. Программа 

требует указать вот что – при вращении фрагмента 2 вокруг стыковочной связи надо 

сделать минимальным угол между направляющим вектором такой-то связи фрагмента 1 и 

направляющим вектором такой-то связи фрагмента 2.   

 

В нашем случае потребуем, чтобы ориентация фрагмента 2 была, как на приведенных 

выше рисунках. Это значит, что вектор, проведенный от атома 2 к атому 3 во фрагменте 1, 

и вектор, проведенный от атома 1 к атому 3 во фрагменте 2, должны составить между 

собой минимальный угол. Это и сказано на условном языке в строчках 4-5 и 9-10 файла с 

исходными данными. Теперь структура этого файла и скупые комментарии в нем должны 

полностью проясниться. 

 

Конечно, все комментарии можно из этого файла убрать, поскольку программа их не 

читает. Получится следующий текст. 

 

Fragm1  

2    

4   

2   

3    

Fragm2  

1   

2   

1   

3   

Joint  

 

Но я предпочитаю этого не делать. Программа в таком бедном тексте ориентируется 

уверенно, а я – нет. 

 

В среде MatLab вызовем программу, которая занимается соединением двух фрагментов 

 

JoinFragments 

 

Получаем картинку 
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Вполне приличный пропилен. На первый взгляд. Однако надо разобраться более подробно 

со всеми свойствами полученной модели. Проверяем все текстовые файлы, появившиеся в 

папке Joint. На второй взгляд тоже всѐ прилично.  

 

Далее проходим привычную уже последовательность вызовов программ, имея в виду, что 

программа JoinFragments уже подготовила нужное название модели Joint в файле 

ToCalculate.ini. 

 

symlev.exe 

Распознана группа низшей симметрии  Cs. Небогато, но отделились 17 координат 

симметрии, описывающих движения в плоскости, где лежат все атомы винильной 

группировки, и 6 координат симметрии, описывающих движения, перпендикулярные этой  

плоскости. Уже хорошо для вдумчивого исследователя. 

MatrixT 

diag1 
Из файла ms.txt узнаем, что число колебаний в двух блоках симметрии составляет  14  и 6. 

Значит, в первом блоке симметрии нашлось три зависимости между координатами, и они 

исключены. Тоже правильно. 

 

Теперь самое интересное. 

Umiu 

 

В этой панели даем последовательность команд: 

File -> New Umiu for… 

Естественно, для модели Joint. 

Edit -> Import U-Miu of model… 

Находим в диалоговом окне модель FRAGM1. В списке параметров что-то появляется. 

Edit -> Import U-Miu of model… 
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Находим в диалоговом окне модель FRAGM2. В списке параметров появляется еще что-

то. 

File -> Save Umiu 

File -> Save Usparse.txt 

File -> Save Miu.txt dmdqSparse.txt 

File -> Exit 

 

Пробуем рассчитать частоты и интенсивности. 

MatrixU 

Ошибок не возникло, значит, хотя бы какие-то диагональные силовые элементы встали на 

свои места. 

diag2 

intir 

 

Проверяем качество расчета. Сравним полученные частоты и интенсивности с 

приведенными в книге [2], стр. 119. Заодно припишем полосам поглощения нашей модели 

Joint полуширины соответствующих полос, найденных для оптимизированной модели 

пропилена, чтобы построить спектральную кривую. 

 

  
Joint 

   
Propylene 

 
Frequency Intencity Sigma 

 
Frequency Intencity Sigma 

 
1/cm abs units 1/cm 

 
1/cm abs units 1/cm 

1 384.1674 0.07 8 1 423.15 0.177 8 

2 863.3366 0.48 15 2 898.7 0.13 15 

3 963.303 5.56 15 3 961.5 0.33 15 

4 1037.749 3.51 8 4 1156.85 0.083 8 

5 1290.879 2.92 18 5 1294.72 1.12 18 

6 1410.677 8.3 11 6 1382.04 2.48 11 

7 1459.207 0.06 16 7 1411.65 0.544 16 

8 1493.317 8.94 16 8 1458.4 3.45 16 

9 1685.137 5.81 20 9 1639.99 4.75 20 

10 2883.087 17.88 28 10 2894.06 14.2 28 

11 2967.649 11.34 28 11 2968.63 9.77 28 

12 3008.432 4.99 28 12 3004.38 6.18 28 

13 3057.712 2.61 28 13 3017.43 1.082 28 

14 3099.744 6.26 28 14 3099.97 10.77 28 

15 556.1032 6.27 8 15 565 2.03 8 

16 944.1836 14.24 15 16 894.65 13.39 15 

17 979.7379 14.12 15 17 989.45 8.64 15 

18 1044.733 2.41 25 18 1046.93 3.77 25 

19 1459.05 0.01 16 19 1458.97 2.32 16 

20 2967.197 10.61 28 20 2967.16 8.84 28 

 

 

Некоторые частоты и интенсивности получаются близкими к результатам для 

оптимизированного пропилена. Некоторые заметно отличаются. При необходимости 

можно будет уточнить параметры нашей модели с помощью программ решения обратных 

задач. 
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Сравним теперь спектральные  кривые ИК поглощения для двух моделей.  
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Спектральная кривая ИК поглощения для модели Joint 
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Спектральная кривая ИК поглощения для оптимизированной модели пропилена.  
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Мы заранее решили не слишком тщательно ухаживать за системой параметров модели Joint, даже 

за некоторыми геометрическими параметрами. Мы ожидали, что наша сравнительно быстро 

приготовленная модель не будет воспроизводить экспериментальный спектр с такой точностью, 

как оптимизированная. Так насколько наша новая модель хуже? 

 

На этот вопрос невозможно ответить. Да по-хорошему, его нельзя и задавать в такой 

формулировке. Если вам придется на какой-то конференции мучиться таким вопросом, то 

прикиньте сначала – в контексте данной конференции всем ли присутствующим и докладчику 

будет понятно, зачем вы сравниваете его решение с каким-то другим. Если в этом не уверены, то 

обозначьте сначала, для каких прикладных или фундаментальных задач вы собираетесь 

использовать модель докладчика или модель, на которую вы ссылаетесь. Тогда и спросите, 

достаточно ли адекватна такая-то модель данной постановке исследования. С достаточной ли 

точностью она будет воспроизводить прогнозируемые и наблюдаемые явления. Только такая 

постановка вопроса выглядит профессиональной.  

 

Дело в том, что оптимизация моделей и их параметров всегда выполняется под решение 

определенного круга задач. В книге [2], стр. 119 приведены такие результаты, когда модель 

пропилена была оптимизирована под наилучшее воспроизведение литературных данных 

по частотам и ИК интенсивностям данного вещества, пропилена. В источнике не 

приведены эти данные, я их тоже не привожу. Ведь в другом спектральном эксперименте 

могут получиться совсем не такие данные. Более того, если вы почитаете неувядаемую 

книгу М.А. Ельяшевича [4], то найдете там массу глубоких физических идей. Например, 

а) из эксперимента вообще невозможно извлечь информацию о так называемой 

фундаментальной нормальной частоте колебаний, можно извлечь только частоту 

квантового перехода между уровнями энергии с квантовыми числами 0 и 1 (а мы в теории 

и расчетах получаем именно фундаментальную частоту); б) даже если мы из эксперимента 

как-то восстановим картину всех низших уровней энергии для данного нормального 

колебания, то это не значит, что мы найдем параметр параболической потенциальной ямы 

в гармоническом приближении для одномерного квантового осциллятора (а мы 

пользуемся именно этим параметром при расчете данной частоты нормального 

колебания). И так далее. Кошмар какой-то для неопытного исследователя.  

 

Мы собираемся стать опытными исследователями. Нас все эти физические ужасы не 

смутят. Если мы работаем над технической проблемой создания банка моделей, 

оптимизированных под воспроизведение ИК спектров органических соединений, мы и 

будем так действовать, получая в специфической постановке обратных спектральных 

задач именно такую оптимизированную систему молекулярных параметров. Если нам 

придется работать над системой моделей, хорошо передающих так называемые бета-

факторы, необходимые для прогнозирования изотопного фракционирования в продуктах 

биогенеза,  то мы, возможно, найдем другую параметризацию этих же моделей. Если 

понадобится точный прогноз термодинамических свойств органических веществ, нам 

могут понадобиться вообще другие модели, со всеми внутренними вращениями, 

которыми мы частенько пренебрегали раньше.  Просмотрите внимательно все 

нормальные колебания модели Joint или оптимизированной модели PropyleneML. Обе эти 

модели не содержат колебательных координат для описания внутреннего вращения 

группы CH3 как целого. Что же это за оптимизация? Для термодинамики она явно не 

годится. Но для некоторых спектроскопических задач – вполне.  
 

Нашу гордость теперь может составлять сознание того, что мы можем профессионально ответить 

на такой грамотный вопрос, связанный с методикой фрагментного формирования моделей.  

Насколько наш прогноз может отличаться от оптимизированного, если мы не учтем возможное 

изменение параметров модели в области стыка?  Покажем на примере только что полученной 

модели Joint, как мы можем ответить на этот вопрос. 
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Поухаживаем за списком параметров модели Joint, который появляется на панели Umiu, удалив из 

него все строки с нулевыми значениями всех параметров. После сохранения фала Umiu.mat 

получим файл u_list.txt с минимизированным списком параметров: 

 

1 1 14.2 0 0 0  qq     1    2  

 1 2 0.1 NaN 0 0  qq     1    2 /     2    3  

 1 3 0 NaN 0 0.5  qq     1    2 /     2    4  

 1 9 0.42 NaN NaN NaN  qa     1    2 /     1    2    3  

 2 2 8.55 0.719 0.493 NaN  qq     2    3  

 2 3 0.21 NaN -0.04 0.2  qq     2    3 /     2    4  

 2 9 0.2 NaN 0.481 NaN  qa     2    3 /     1    2    3  

 2 13 0.05 NaN 0.6 NaN  qa     2    3 /     3    2    4  

 3 3 7 0 -0.3 NaN   qq     2    4  

 3 6 0.415 NaN 0.05 NaN  qq     2    4 /     4    7  

 3 10 0.415 NaN 0.05 NaN  qa     2    4 /     1    2    4  

 3 13 0 NaN 0.5 NaN  qa     2    4 /     3    2    4  

 4 5 0.03 NaN 0.041 NaN  qq     1    5 /     1    6  

 4 14 0.12 NaN 0.551 NaN  qa     1    5 /     5    1    6  

 6 6 8.03 0.305 0.83 NaN  qq     4    7  

 6 7 0.06 NaN 0.28 NaN  qq     4    7 /     4    8  

 6 15 0.3 NaN -0.3 NaN  qa     4    7 /     2    4    7  

 6 18 0.3 NaN -0.3 NaN  qa     4    7 /     7    4    8  

 6 20 0 NaN -0.38 NaN  qa     4    7 /     8    4    9  

 9 9 0.77 NaN NaN NaN  aa     1    2    3  

 9 11 -0.025 NaN NaN NaN  aa     1    2    3 /     2    1    5  

 9 12 0.095 NaN NaN NaN  aa     1    2    3 /     2    1    6  

 10 10 0.77 NaN NaN NaN  aa     1    2    4  

 10 11 -0.025 NaN NaN NaN  aa     1    2    4 /     2    1    5  

 10 12 0.095 NaN NaN NaN  aa     1    2    4 /     2    1    6  

 13 13 0.57 NaN NaN NaN  aa     3    2    4  

  13   20   0.0000      NaN      NaN      NaN aa     3    2    4 /     8    4    9  

 14 14 0.57 NaN NaN NaN  aa     5    1    6  

 15 15 0.92 NaN NaN NaN  aa     2    4    7  

 15 16 -0.025 NaN NaN NaN  aa     2    4    7 /     2    4    8  

 15 18 -0.034 NaN NaN NaN  aa     2    4    7 /     7    4    8  

 18 18 0.71 NaN NaN NaN  aa     7    4    8  

 18 19 -0.034 NaN NaN NaN  aa     7    4    8 /     7    4    9  

 21 21 0.35 NaN NaN NaN  rr     3    2    4    1  

 21 22 0.047 NaN NaN NaN  rr     3    2    4    1 /     6    1    5    2  

 22 22 0.35 NaN NaN NaN  rr     6    1    5    2  

 23 23 0.755 NaN NaN NaN  hh     3    2    4    5    1    6  
 

На основе этого файла приготовим файл исходных данных  params_std.txt для программы 

IRSerrors.m, с которой мы знакомились в главе 4. Сейчас эта программа нам решит вопрос, 

похожий на производственно-методический. В файле params_std.txt мы укажем предполагаемые 

стандартные отклонения тех параметров, которые мы считаем не вполне определенными в момент 

стыковки двух заготовленных фрагментов FRAGM1 и FRAGM2. Пусть эти стандартные 

отклонения составляют 5% от введенных значений самих параметров. Для параметров, в которых 

мы «совершенно» уверены, вписываем значение, равное нулю.  Получается такое содержимое 

файла params_std.txt: 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0.05 

0 0 0 0 
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0 0 0 0 

0.14 0 0.0005 0 

0.008 0 0.001 0 

0.008 0 0.001 0 

0 0 0.01 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0.014 0 0 0 

0 0 0 0 

0 0 0 0 

0.01 0 0 0 

0  0 0  0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0 0 0 0 

0.007 0 0 0 

0 0 0 0 

0 0 0 0 

0.014 0 0 0 

 

IRSerrors 

 

Программа трудилась 94 секунды и дала такие результаты в файле IRSstatistics.txt: 

  383.89  1.33  0.07  0.00  

  863.06  3.18  0.45  0.02  

  963.31  0.28  5.72  0.05  

 1037.67  0.81  3.63  0.04  

 1290.84  0.92  2.91  0.05  

 1410.68  0.27  8.13  0.08  

 1459.21  0.00  0.09  0.00  

 1493.24  0.94  8.80  0.09  

 1685.08  1.19  5.87  0.07  

 2883.08  0.09  5.66  0.02  

 2967.65  0.01 23.96  0.00  

 3008.43  0.00  4.46  0.04  

 3057.71  0.02  2.68  0.14  

 3099.74  0.01  7.51  0.03  

  556.27  2.38  6.34  0.06  

  944.18  0.05 14.17  0.16  

  980.28  3.65 14.31  0.11  

 1044.89  1.24  2.51  0.30  

 1459.05  0.01  0.00  0.00  

 2967.20  0.00 22.91  0.00 

В каждой строке указаны: среднее значение частоты, среднее квадратичное отклонение частоты, 

средняя интенсивность в ИК спектре, среднее квадратичное отклонение интенсивности.  
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Из этих данных совершенно ясно видно, какие частоты и интенсивности совершенно не 

подвержены изменениям, связанным с неопределенностью параметров в области стыка 

фрагментов, какие подвержены слабо, а какие можно значительно улучшить, если поухаживать за 

системой параметров стыка. Мы узнаем, что из-за неопределенности порядка 5% от величин 

параметров стыковочной связи наиболее сильно страдают значения частот 863 и 980 см
-1

. Но ведь 

эти возможные погрешности значительно меньше тех неустранимых невязок (10-20 см
-1

), которые 

остались после решения обратной механической задачи! 

 

Вот как выглядит профессиональный ответ на грамотно поставленный вопрос. Ни один 

специалист, разрабатывающий методику решения своих задач на основе фрагментного расчета, не 

придерется. 

 

Для дальнейших употреблений сохраняем нулевое приближение модели пропилена в папке 

Propylene0ML. Папку Joint теперь можно освободить под будущую работу с формированием 

другой модели из других фрагментов. 
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